Bug 1281675 - [gdm] gnome-terminal fails to start up: GDBus.Error:org.freedeskt op.DBus.Error.Spawn.ChildExited
[gdm] gnome-terminal fails to start up: GDBus.Error:org.freedeskt op.DBus.Err...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
: 1281885 1283213 1284883 1289488 (view as bug list)
Depends On:
Blocks: F24AlphaBlocker
  Show dependency treegraph
 
Reported: 2015-11-13 00:59 EST by Joachim Frieben
Modified: 2017-02-04 05:48 EST (History)
28 users (show)

See Also:
Fixed In Version: gdm-3.19.4.1-4.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 07:02:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDM debug log file of login procedure for GNOME default session (170.70 KB, text/plain)
2016-02-07 12:27 EST, Joachim Frieben
no flags Details
GDM debug log file of login procedure for GNOME on Wayland session (74.93 KB, text/plain)
2016-02-07 12:28 EST, Joachim Frieben
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 761568 None None None 2016-02-04 13:45 EST

  None (edit)
Description Joachim Frieben 2015-11-13 00:59:12 EST
Description of problem:
For the current development tree, gnome-terminal refuses to start up.

Version-Release number of selected component (if applicable):
gnome-terminal-3.18.1-1.fc23

How reproducible:
Always

Steps to Reproduce:
1. Launch gnome-terminal from the command line.

Actual results:
gnome-terminal aborts returning the error message:

    "Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus
.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 10"

Expected results:
gnome-terminal starts up as expected.

Additional info:
The culprit is probably a different component because gnome-terminal-3.18.1-1.fc23 has stopped working only recently.
Comment 1 Joachim Frieben 2015-11-19 02:22:57 EST
Issue affects the current Fedora development tree including package gnome-terminal-3.18.2-1.fc24.
Comment 2 Christian Persch (GNOME) 2015-11-19 05:50:06 EST
https://wiki.gnome.org/Apps/Terminal/FAQ#Exit_status_10
Comment 3 Joachim Frieben 2015-11-19 07:57:33 EST
In the current Fedora development tree, GNOME is running on Wayland by default. Only then, gnome-terminal does -not- start up when launched from the application menu, and only then, it returns the error message reported in the original report when launched from the command line in an xterm window.
As soon as the session type is changed to GNOME on Xorg, gnome-terminal starts up correctly without error message.
Comment 4 Vartan Simonian 2015-11-20 18:57:02 EST
Experiencing the exact same problem on rawhide, except the problem isn't limited to gnome-terminal: I can't start nautilus and a whole suite of GTK applications due to the same error on the Wayland session. On Xorg, everything works OK.
Comment 5 ooyama yosiyuki 2015-12-03 15:12:29 EST
In my case, the next method enables gnome-terminal starting up at gnome default (maybe wayland is enabled).

This method is 

step 1: Once logout,
step 2; then login at "GNOME on Xorg" (When at login screen , select "GNOME on Xorg"), It should be not "GNOME"-login but "GNOME on Xorg"-login,
step 3: then logout,
step 4: then login at "GNOME".  at rawhide, wayland is default.   (maybe wayland is enabled).

this method eneble gnome-terminal starting up.

As a prepare for this procedure, you must have set a user password.
If the user password is not set, because the password input-bar at login-screen will be skipped,
therefore gnome-switching menu ( Gnome / Gnome classic / Gnome on wayland/ ) is also skipped,
therefore you can not perform the procedure.
Comment 6 Adam Williamson 2015-12-04 17:03:09 EST
*** Bug 1283213 has been marked as a duplicate of this bug. ***
Comment 7 Adam Williamson 2015-12-04 17:04:35 EST
*** Bug 1284883 has been marked as a duplicate of this bug. ***
Comment 8 Adam Williamson 2015-12-04 17:08:24 EST
I see this on the 2015-12-04 Rawhide nightly live, just boot the image and try to run terminal, it always fails.

In addition to the messages folks have posted already, I see this in the journal:

Dec 04 17:01:05 localhost dbus-daemon[1492]: Activating service name='org.gnome.Terminal'
Dec 04 17:01:05 localhost org.gnome.Terminal[1492]: Unable to init server: Could not connect: Connection refused
Dec 04 17:01:05 localhost org.gnome.Terminal[1492]: Failed to parse arguments: Cannot open display:
Dec 04 17:01:05 localhost dbus-daemon[1492]: Activated service 'org.gnome.Terminal' failed: Process org.gnome.Terminal exited with status 10
Comment 9 Adam Williamson 2015-12-04 17:09:33 EST
Proposing as an Alpha blocker, criterion: "It must be possible to run the default web browser and a terminal application from all release-blocking desktop environments." - https://fedoraproject.org/wiki/Fedora_24_Alpha_Release_Criteria#Required_applications
Comment 10 Adam Williamson 2015-12-04 17:13:25 EST
Rather more stuff seems to go wrong when trying to launch from the overview, along with the same errors you get trying to run 'gnome-terminal' from an xterm (which is how I got the log in #c8):

Dec 04 17:10:19 localhost dbus-daemon[1492]: Activating service name='org.gnome.ControlCenter.SearchProvider'
Dec 04 17:10:19 localhost dbus-daemon[1492]: Activating service name='org.gnome.Boxes.SearchProvider'
Dec 04 17:10:19 localhost dbus-daemon[1492]: Activating service name='org.gnome.Calculator.SearchProvider'
Dec 04 17:10:19 localhost dbus-daemon[1492]: Activating service name='org.gnome.clocks'
Dec 04 17:10:19 localhost dbus-daemon[1492]: Activating service name='org.gnome.Contacts.SearchProvider'
Dec 04 17:10:19 localhost dbus-daemon[1492]: Activating service name='org.gnome.Documents'
Dec 04 17:10:19 localhost dbus-daemon[1492]: Activating service name='org.gnome.Nautilus'
Dec 04 17:10:19 localhost dbus-daemon[1492]: Activating service name='org.gnome.Bijiben.SearchProvider'
Dec 04 17:10:19 localhost dbus-daemon[1492]: Activating service name='org.gnome.seahorse.Application'
Dec 04 17:10:19 localhost dbus-daemon[1492]: Activating service name='org.gnome.Software'
Dec 04 17:10:19 localhost dbus-daemon[1492]: Activating service name='org.gnome.Terminal'
Dec 04 17:10:19 localhost dbus-daemon[1492]: Successfully activated service 'org.gnome.Calculator.SearchProvider'
Dec 04 17:10:19 localhost dbus-daemon[1492]: Successfully activated service 'org.gnome.Boxes.SearchProvider'
Dec 04 17:10:20 localhost dbus-daemon[1492]: Successfully activated service 'org.gnome.ControlCenter.SearchProvider'
Dec 04 17:10:20 localhost dbus-daemon[1492]: Successfully activated service 'org.gnome.clocks'
Dec 04 17:10:20 localhost org.gnome.ControlCenter.SearchProvider[1492]: Unable to init server: Could not connect: Connection refused
Dec 04 17:10:20 localhost org.gnome.clocks[1492]: Unable to init server: Could not connect: Connection refused
Dec 04 17:10:20 localhost org.gnome.clocks[1492]: (gnome-clocks:4278): Gtk-WARNING **: cannot open display:
Dec 04 17:10:20 localhost org.gnome.ControlCenter.SearchProvider[1492]: (gnome-control-center-search-provider:4273): Gtk-WARNING **: cannot open display:
Dec 04 17:10:20 localhost org.gnome.Shell.desktop[1589]: Gjs-Message: JS LOG: Received error from DBus search provider org.gnome.clocks.desktop: Gio.DBusError: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
Dec 04 17:10:20 localhost org.gnome.Shell.desktop[1589]: Gjs-Message: JS LOG: Received error from DBus search provider gnome-control-center.desktop: Gio.DBusError: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
Dec 04 17:10:20 localhost org.gnome.Terminal[1492]: Unable to init server: Could not connect: Connection refused
Dec 04 17:10:20 localhost org.gnome.Terminal[1492]: Failed to parse arguments: Cannot open display:
Dec 04 17:10:20 localhost dbus-daemon[1492]: Activated service 'org.gnome.Terminal' failed: Process org.gnome.Terminal exited with status 10
Dec 04 17:10:20 localhost org.gnome.Shell.desktop[1589]: Gjs-Message: JS LOG: Received error from DBus search provider org.gnome.Terminal.desktop: Gio.DBusError: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 10
Dec 04 17:10:20 localhost dbus-daemon[1492]: Successfully activated service 'org.gnome.Software'
Dec 04 17:10:20 localhost org.gnome.Software[1492]: Unable to init server: Could not connect: Connection refused
Dec 04 17:10:20 localhost org.gnome.Software[1492]: (org.gnome.Software:4291): Gtk-WARNING **: cannot open display:
Dec 04 17:10:20 localhost org.gnome.Shell.desktop[1589]: Gjs-Message: JS LOG: Received error from DBus search provider org.gnome.Software.desktop: Gio.DBusError: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
Dec 04 17:10:20 localhost dbus-daemon[1492]: Successfully activated service 'org.gnome.Nautilus'
Dec 04 17:10:20 localhost org.gnome.Nautilus[1492]: Unable to init server: Could not connect: Connection refused
Dec 04 17:10:20 localhost org.gnome.Nautilus[1492]: (nautilus:4285): Gtk-WARNING **: cannot open display:
Dec 04 17:10:20 localhost org.gnome.seahorse.Application[1492]: Unable to init server: Could not connect: Connection refused
Dec 04 17:10:20 localhost org.gnome.seahorse.Application[1492]: seahorse: Cannot open display:
Dec 04 17:10:20 localhost org.gnome.Shell.desktop[1589]: Gjs-Message: JS LOG: Received error from DBus search provider org.gnome.Nautilus.desktop: Gio.DBusError: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
Dec 04 17:10:20 localhost dbus-daemon[1492]: Activated service 'org.gnome.seahorse.Application' failed: Process org.gnome.seahorse.Application exited with status 1
Dec 04 17:10:20 localhost org.gnome.Shell.desktop[1589]: Gjs-Message: JS LOG: Received error from DBus search provider seahorse.desktop: Gio.DBusError: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.seahorse.Application exited with status 1
Dec 04 17:10:20 localhost dbus-daemon[1492]: Successfully activated service 'org.gnome.Documents'
Dec 04 17:10:20 localhost org.gnome.Documents[1492]: Unable to init server: Could not connect: Connection refused
Dec 04 17:10:20 localhost org.gnome.Documents[1492]: (org.gnome.Documents:4283): Gtk-WARNING **: cannot open display:
Dec 04 17:10:20 localhost org.gnome.Bijiben.SearchProvider[1492]: Unable to init server: Could not connect: Connection refused
Dec 04 17:10:20 localhost org.gnome.Bijiben.SearchProvider[1492]: (bijiben-shell-search-provider:4287): Gtk-WARNING **: cannot open display:
Dec 04 17:10:20 localhost dbus-daemon[1492]: Activated service 'org.gnome.Bijiben.SearchProvider' failed: Process org.gnome.Bijiben.SearchProvider exited with status 1
Dec 04 17:10:20 localhost dbus-daemon[1492]: Activating service name='org.gnome.Terminal'
Dec 04 17:10:20 localhost org.gnome.Shell.desktop[1589]: Gjs-Message: JS LOG: Received error from DBus search provider org.gnome.Documents.desktop: Gio.DBusError: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
Dec 04 17:10:20 localhost org.gnome.Shell.desktop[1589]: Gjs-Message: JS LOG: Received error from DBus search provider bijiben.desktop: Gio.DBusError: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Bijiben.SearchProvider exited with status 1
Dec 04 17:10:21 localhost org.gnome.Terminal[1492]: Unable to init server: Could not connect: Connection refused
Dec 04 17:10:21 localhost org.gnome.Terminal[1492]: Failed to parse arguments: Cannot open display:
Dec 04 17:10:21 localhost dbus-daemon[1492]: Activated service 'org.gnome.Terminal' failed: Process org.gnome.Terminal exited with status 10
Dec 04 17:10:21 localhost org.gnome.Terminal.desktop[4316]: Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 10
Dec 04 17:10:21 localhost dbus-daemon[1492]: Successfully activated service 'org.gnome.Contacts.SearchProvider'
Dec 04 17:10:21 localhost dbus[1019]: [system] Activating via systemd: service name='org.bluez' unit='dbus-org.bluez.service'
Dec 04 17:10:46 localhost dbus[1019]: [system] Failed to activate service 'org.bluez': timed out
Comment 11 Adam Williamson 2015-12-04 17:31:34 EST
*** Bug 1281885 has been marked as a duplicate of this bug. ***
Comment 12 Giulio 'juliuxpigface' 2015-12-08 05:02:13 EST
*** Bug 1289488 has been marked as a duplicate of this bug. ***
Comment 13 Adam Williamson 2015-12-14 18:57:21 EST
TEST TEST TEST sorry, i'm testing a blockerbugs change, this will be reverted shortly
Comment 14 Parag Nemade 2015-12-21 09:00:24 EST
Today I installed rawhide compose 20151219 in VM. First I installed in minimal mode and then pulled Fedora Workstation group. I then started Gnome and then every attempt of starting gnome-terminal failed. I then looked into journalctl and here is the output log -> https://pnemade.fedorapeople.org/f24-journalctl.log

I think this issue exists since a month as in my previous rawhide VM also I have seen this issue. The relevant log is
Dec 21 13:45:35 localhost.localdomain dbus-daemon[1805]: Activating service name='org.gnome.Terminal'
Dec 21 13:45:35 localhost.localdomain org.gnome.Shell.desktop[1836]: (gnome-shell:1836): Gjs-WARNING **: JS ERROR: Error: can't convert this._frame to an integer
Dec 21 13:45:35 localhost.localdomain org.gnome.Shell.desktop[1836]: Animation<._showFrame@resource:///org/gnome/shell/ui/animation.js:53
Dec 21 13:45:35 localhost.localdomain org.gnome.Shell.desktop[1836]: wrapper@resource:///org/gnome/gjs/modules/lang.js:178
Dec 21 13:45:35 localhost.localdomain org.gnome.Shell.desktop[1836]: Animation<._update@resource:///org/gnome/shell/ui/animation.js:65
Dec 21 13:45:35 localhost.localdomain org.gnome.Shell.desktop[1836]: wrapper@resource:///org/gnome/gjs/modules/lang.js:178
Dec 21 13:45:35 localhost.localdomain org.gnome.Terminal[1805]: Unable to init server: Could not connect: Connection refused
Dec 21 13:45:35 localhost.localdomain org.gnome.Terminal[1805]: Failed to parse arguments: Cannot open display:
Dec 21 13:45:35 localhost.localdomain dbus-daemon[1805]: Activated service 'org.gnome.Terminal' failed: Process org.gnome.Terminal exited with status 10
Dec 21 13:45:35 localhost.localdomain org.gnome.Terminal.desktop[2855]: Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 10
Comment 15 Matthias Clasen 2015-12-21 09:03:21 EST
can you find the stacktrace ? it doesn't crash here...
Comment 16 Michael Catanzaro 2015-12-21 09:41:59 EST
To clarify, the stacktrace in the comment above:

Dec 21 13:45:35 localhost.localdomain org.gnome.Shell.desktop[1836]: (gnome-shell:1836): Gjs-WARNING **: JS ERROR: Error: can't convert this._frame to an integer
Dec 21 13:45:35 localhost.localdomain org.gnome.Shell.desktop[1836]: Animation<._showFrame@resource:///org/gnome/shell/ui/animation.js:53
Dec 21 13:45:35 localhost.localdomain org.gnome.Shell.desktop[1836]: wrapper@resource:///org/gnome/gjs/modules/lang.js:178
Dec 21 13:45:35 localhost.localdomain org.gnome.Shell.desktop[1836]: Animation<._update@resource:///org/gnome/shell/ui/animation.js:65
Dec 21 13:45:35 localhost.localdomain org.gnome.Shell.desktop[1836]: wrapper@resource:///org/gnome/gjs/modules/lang.js:178

Is a bug that should be reported against gnome-shell, but it's probably unrelated to this issue. Everything below that is relevant to this issue.
Comment 17 Adam Williamson 2015-12-21 12:05:00 EST
Discussed at 2015-12-21 QA meeting, acting as a blocker review meeting (as we only had this to review): https://meetbot-raw.fedoraproject.org/teams/fedora-qa/fedora-qa.2015-12-21-16.01.log.txt . Accepted as a blocker: not everything about this bug is clear, but with #c8, #c14 and Chris Murphy's mail from yesterday - https://lists.fedoraproject.org/archives/list/test%40lists.fedoraproject.org/thread/OIC5UWZUL66LEL3IL5HYJCKAL3TUHK2Y/ - it at least seems clear that it's preventing multiple people from running apps including the terminal on fresh live image boots, thus a violation of "It must be possible to run the default web browser and a terminal application from all release-blocking desktop environments.", https://fedoraproject.org/wiki/Fedora_24_Alpha_Release_Criteria#Required_applications
Comment 18 Chris Murphy 2015-12-21 15:42:10 EST
FWIW, I run into this bug with Nautilus, Terminal, and gedit, in the live environment booted from a USB stick written with the 20151219 Workstation ISO. A journalctl | grep -i wayland spits back no results, so wayland doesn't seem to be used for live boots at all.
Comment 19 Parag Nemade 2015-12-21 22:22:07 EST
I am not able to get stacktrace, I tried bt and also "thread apply all bt full" but no stack trace. I do have few debuginfo rpms installed not all.


$ gdb /usr/bin/gnome-terminal
<snip>
Reading symbols from /usr/bin/gnome-terminal...Reading symbols from /usr/lib/deb
ug/usr/bin/gnome-terminal.debug...done.
done.
(gdb) run
Starting program: /usr/bin/gnome-terminal
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".

** (gnome-terminal:3707): WARNING **: Couldn't register with accessibility bus:
Did not receive a reply. Possible causes include: the remote application did not
 send a reply, the message bus security policy blocked the reply, the reply time
out expired, or the network connection was broken.
[New Thread 0x7fffe3ad6700 (LWP 3711)]
[New Thread 0x7fffe3285700 (LWP 3712)]
Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Er
ror calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedeskt
op.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 1
0
[Thread 0x7fffe3285700 (LWP 3712) exited]
[Thread 0x7fffe3ad6700 (LWP 3711) exited]
[Inferior 1 (process 3707) exited with code 01]
Missing separate debuginfos, use: dnf debuginfo-install bzip2-libs-1.0.6-19.fc24
.x86_64 gvfs-client-1.27.3-1.fc24.x86_64 harfbuzz-1.1.1-1.fc24.x86_64 libcanberr
a-0.30-10.fc23.x86_64 libcanberra-gtk3-0.30-10.fc23.x86_64 libgcc-5.3.1-2.fc24.x
86_64 libogg-1.3.2-4.fc23.x86_64 libtdb-1.3.8-2.fc24.x86_64 libtool-ltdl-2.4.6-7
.fc24.x86_64 libvorbis-1.3.4-5.fc23.x86_64 mesa-libEGL-11.2.0-0.devel.2.56aff6b.
fc24.x86_64 mesa-libgbm-11.2.0-0.devel.2.56aff6b.fc24.x86_64 mesa-libGL-11.2.0-0
.devel.2.56aff6b.fc24.x86_64 mesa-libglapi-11.2.0-0.devel.2.56aff6b.fc24.x86_64
mesa-libwayland-egl-11.2.0-0.devel.2.56aff6b.fc24.x86_64 PackageKit-gtk3-module-
1.0.11-1.fc24.x86_64
(gdb) thread apply all bt full
(gdb) bt
No stack.
(gdb)

I have run this from emacs-terminal.
Comment 20 Gerben Welter 2016-01-05 15:57:27 EST
I've been running into this bug also on my rawhide installation. It seems that SElinux is denying systemd to access a unix socket:

type=AVC msg=audit(1451423116.859:83): avc:  denied  { create } for  pid=1 comm="systemd" scontext=system_u:system_r:init_t:s0 tcontext=system_u:system_r:unconfined_service_t:s0 tclass=unix_stream_socket permissive=0

Rebooting with SElinux disabled makes gnome-terminal and nautilus start again.
Comment 21 Gerben Welter 2016-01-09 07:41:45 EST
The update to selinux-policy-3.13.1-165 seems to have fixed this for me. Gnome-terminal and Nautilus start again under Wayland.
Comment 22 Onyeibo Oku 2016-01-10 00:29:38 EST
(In reply to Gerben Welter from comment #21)
> The update to selinux-policy-3.13.1-165 seems to have fixed this for me.
> Gnome-terminal and Nautilus start again under Wayland.

Your experience might be unrelated.  I am still getting that error message after installing selinux-policy-3.13.1-165.  With ALT+F2, I am able to execute nautilus and gedit but they won't run from the "Activities" menu.

I found these entries in the journal:

For gnome.terminal
------------------
dbus-daemon[2214]: Activated service 'org.gnome.Terminal' failed: Process org.gnome.Terminal exited with status 10
Jan 10 05:35:53 asusprime.schemefusion.com org.gnome.Terminal.desktop[2869]: Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 10


For nautilus:
-------------
org.gnome.Nautilus[2214]: Unable to init server: Could not connect: Connection refused
org.gnome.Nautilus[2214]: (nautilus:2779): Gtk-WARNING **: cannot open display:


For gedit -- also includes an attempt to start gnome-terminal from xterm:
-------------------------------------------------------------------------
dbus-daemon[2246]: Successfully activated service 'org.gnome.gedit'
Jan 10 05:57:16 asusprime.schemefusion.com org.gnome.gedit[2246]: Unable to init server: Could not connect: Connection refused
Jan 10 05:57:16 asusprime.schemefusion.com org.gnome.gedit[2246]: (gedit:2944): Gtk-WARNING **: cannot open display:
Jan 10 05:57:43 asusprime.schemefusion.com org.gnome.Shell.desktop[2264]: Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0xe000f8 (Untitled D)
Jan 10 05:57:52 asusprime.schemefusion.com org.gnome.Shell.desktop[2264]: (gedit:2947): Gtk-WARNING **: Negative content width while allocating gadget
Jan 10 05:58:28 asusprime.schemefusion.com xterm.desktop[2959]: xterm: cannot load font '-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1'
Jan 10 05:58:42 asusprime.schemefusion.com dbus-daemon[2246]: Activating service name='org.gnome.Terminal'
Jan 10 05:58:42 asusprime.schemefusion.com org.gnome.Terminal[2246]: Unable to init server: Could not connect: Connection refused
Jan 10 05:58:42 asusprime.schemefusion.com org.gnome.Terminal[2246]: Failed to parse arguments: Cannot open display:
Jan 10 05:58:42 asusprime.schemefusion.com dbus-daemon[2246]: Activated service 'org.gnome.Terminal' failed: Process org.gnome.Terminal exited with status 10
Comment 23 Onyeibo Oku 2016-01-10 00:30:51 EST
(In reply to Gerben Welter from comment #21)
> The update to selinux-policy-3.13.1-165 seems to have fixed this for me.
> Gnome-terminal and Nautilus start again under Wayland.

Your experience might be unrelated.  I am still getting that error message after installing selinux-policy-3.13.1-165.  With ALT+F2, I am able to execute nautilus and gedit but they won't run from the "Activities" menu.

I found these entries in the journal:

For gnome.terminal
------------------
dbus-daemon[2214]: Activated service 'org.gnome.Terminal' failed: Process org.gnome.Terminal exited with status 10
Jan 10 05:35:53 asusprime.schemefusion.com org.gnome.Terminal.desktop[2869]: Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 10


For nautilus:
-------------
org.gnome.Nautilus[2214]: Unable to init server: Could not connect: Connection refused
org.gnome.Nautilus[2214]: (nautilus:2779): Gtk-WARNING **: cannot open display:


For gedit -- also includes an attempt to start gnome-terminal from xterm:
-------------------------------------------------------------------------
dbus-daemon[2246]: Successfully activated service 'org.gnome.gedit'
Jan 10 05:57:16 asusprime.schemefusion.com org.gnome.gedit[2246]: Unable to init server: Could not connect: Connection refused
Jan 10 05:57:16 asusprime.schemefusion.com org.gnome.gedit[2246]: (gedit:2944): Gtk-WARNING **: cannot open display:
Jan 10 05:57:43 asusprime.schemefusion.com org.gnome.Shell.desktop[2264]: Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0xe000f8 (Untitled D)
Jan 10 05:57:52 asusprime.schemefusion.com org.gnome.Shell.desktop[2264]: (gedit:2947): Gtk-WARNING **: Negative content width while allocating gadget
Jan 10 05:58:28 asusprime.schemefusion.com xterm.desktop[2959]: xterm: cannot load font '-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1'
Jan 10 05:58:42 asusprime.schemefusion.com dbus-daemon[2246]: Activating service name='org.gnome.Terminal'
Jan 10 05:58:42 asusprime.schemefusion.com org.gnome.Terminal[2246]: Unable to init server: Could not connect: Connection refused
Jan 10 05:58:42 asusprime.schemefusion.com org.gnome.Terminal[2246]: Failed to parse arguments: Cannot open display:
Jan 10 05:58:42 asusprime.schemefusion.com dbus-daemon[2246]: Activated service 'org.gnome.Terminal' failed: Process org.gnome.Terminal exited with status 10
Comment 24 Joachim Frieben 2016-01-10 09:54:44 EST
This issue also occurs in permissive instead of enforcing mode (booting with kernel option enforcing=0) when booting from today's rawhide live image. Therefore, it is -not- caused by SELinux.
Comment 25 Gerben Welter 2016-01-11 13:54:34 EST
Ok, the selinux denial was a red herring. But I read somewhere that selinux disabled and in enforcing mode still can have subtle differences. So that's why I tested with selinux disabled.

I tested again with today's rawhide image. This is the transcript of my actions:

Install VM with Workstation package:

boot with selinux in enforcing mode: no gnome-terminal
reboot with selinux in permissive mode: no gnome-terminal
reboot with selinux disabled: no gnome-terminal

logout, login again with Gnome on Xorg: gnome-terminal starts
logout, login again with Gnome on Wayland: gnome-terminal starts

Reboot with selinux in enforcing mode, login with Gnome on Wayland: gnome-terminal starts

So it seems that when gnome-terminal is able to start with Xorg, something is changed so that gnome-terminal can start in Wayland. Now we have to find out what that is.
Comment 26 Joachim Frieben 2016-01-12 14:39:23 EST
(In reply to Gerben Welter from comment #25)
You actually report what had already been found in comment 5. Moreover, today's rawhide live image reveals the same issue to be present with Xorg.
Since the next GNOME test release, namely 3.19.4, is just around the corner it is probably worth waiting a few days in order to check whether the issue has already been fixed upstream.
Comment 27 Bill Gianopoulos 2016-01-30 11:29:46 EST
I fixed this.  The fix is simple.  Something is going wrong with the upgrade such that the default gdm session is not set up properly.  Although it should be running wayland it seems to be running an xorg session, yet I guess it has some settings that do not work for xorg.

I just changed the settings to GNOME on xorg, logged in then logged out, changed the settings back to the default GNMOE and everything worked like a charm.
Comment 28 Onyeibo Oku 2016-01-30 12:27:42 EST
(In reply to Bill Gianopoulos from comment #27)
> I fixed this.  The fix is simple.  Something is going wrong with the upgrade
> such that the default gdm session is not set up properly.  Although it
> should be running wayland it seems to be running an xorg session, yet I
> guess it has some settings that do not work for xorg.
> 
> I just changed the settings to GNOME on xorg, logged in then logged out,
> changed the settings back to the default GNMOE and everything worked like a
> charm.


Awesome

Is there a Bodhi build with the fix?  I feel like testing something? :-)
Comment 29 Bill Gianopoulos 2016-01-30 12:42:22 EST
(In reply to Onyeibo from comment #28)
> (In reply to Bill Gianopoulos from comment #27)
> > I fixed this.  The fix is simple.  Something is going wrong with the upgrade
> > such that the default gdm session is not set up properly.  Although it
> > should be running wayland it seems to be running an xorg session, yet I
> > guess it has some settings that do not work for xorg.
> > 
> > I just changed the settings to GNOME on xorg, logged in then logged out,
> > changed the settings back to the default GNMOE and everything worked like a
> > charm.
> 
> 
> Awesome
> 
> Is there a Bodhi build with the fix?  I feel like testing something? :-)

This method worked without any fix.  I logged in with the default GNOME session and it seemed to NOT really be running wayland and I got both this exact gnome-terminal error and also the graphical selinux troubleshooter would not launch.  I did a home mess of reinstalls of everything gnome, gdm and dbus that made any sense to no avail.  Then I switched to telling it i wanted an xorg session launched gnome-terminal successfully logged out switch to the default GNOME and it launched wayland and both gnome-termainal and the Selinux troubleshooter worked just fine.
Comment 30 Onyeibo Oku 2016-01-30 13:25:18 EST
(In reply to Bill Gianopoulos from comment #29)
> This method worked without any fix.  I logged in with the default GNOME
> session and it seemed to NOT really be running wayland and I got both this
> exact gnome-terminal error and also the graphical selinux troubleshooter
> would not launch.  I did a home mess of reinstalls of everything gnome, gdm
> and dbus that made any sense to no avail.  Then I switched to telling it i
> wanted an xorg session launched gnome-terminal successfully logged out
> switch to the default GNOME and it launched wayland and both gnome-termainal
> and the Selinux troubleshooter worked just fine.

Well, what do you know? The procedure actually survived a reboot (persistent)!  There has to be a more technical explanation to this.
Comment 31 Bill Gianopoulos 2016-01-30 15:48:32 EST
OK more technical is that evidentally there is something that needs to be done to switch the default gdm login session form xorg to Wayland that is done by the switching from the gdm login screen that is not done during the update form fedora 23 to fedora24.  Now that i identified the real issue here I am sure this will be resolved quickly by people who know much more about this than I do.  My real insight came because I have desktop icons enabled so as soon as I saw icons on the desktop (which does not work under wayland) I knew it ws not really running wayland like it was supposed to be.
Comment 32 Adam Williamson 2016-01-30 18:25:24 EST
It's not that simple, and we've already been around this block once: the same issue occurs on Rawhide nightly live images, nothing to do with upgrades from Fedora 23.
Comment 33 Bill Gianopoulos 2016-01-30 18:31:59 EST
But the problem is not with gnome-terminal at all the problem is that the default GNOME GDM session that is intended to be a wayland session seems to start an xorg session without having other things set up for an xorg session so stuff does not work.  it should really be starting a wayland session in the first place.  I was not at all sure from previous comments that this was known as the real issue.
Comment 34 Adam Williamson 2016-01-30 18:34:39 EST
Someone already said just about the same thing as you in comment #5.
Comment 35 Bill Gianopoulos 2016-01-30 18:50:01 EST
(In reply to awilliam@redhat.com from comment #34)
> Someone already said just about the same thing as you in comment #5.

Well sorry but not good enough english so that i understood the comment.
Comment 36 Bill Gianopoulos 2016-01-30 18:51:19 EST
(In reply to awilliam@redhat.com from comment #34)
> Someone already said just about the same thing as you in comment #5.

So I will never try to help on an alpha bug again.  Thank you so much for playing!
Comment 37 Bill Gianopoulos 2016-01-30 18:52:16 EST
Alpha blocker bug I meant.
Comment 38 Adam Williamson 2016-01-30 19:05:24 EST
It's that we don't appreciate the help - I'm just saying, we were already aware that switching sessions works around the problem, but that still hasn't yet resulted in someone figuring out exactly what the actual bug is.
Comment 39 Sebastian Keller 2016-01-31 06:05:51 EST
I think the problem is related to the switch from the dbus session bus to the user bus. With the session bus, gdm was responsible for launching dbus-daemon and it could set the DISPLAY and XAUTHORITY environment variables for it. With the user bus things work differently, I think. gnome-terminal and nautilus are started via dbus activation, which means that they inherit their environment from the users dbus-daemon instance and without those environment variables set, they can't start under X. You can work around this in the "GNOME on Xorg" session by installing xterm (which does not use dbus activation), launching it from gnome-shell and then in it run "dbus-update-activation-environment DISPLAY XAUTHORITY". This sets the environment variables that are used when dbus-daemon is starting processes. Now you can start gnome-terminal and nautilus.
Comment 40 Bill Gianopoulos 2016-02-03 07:32:48 EST
(In reply to Sebastian Keller from comment #39)
> I think the problem is related to the switch from the dbus session bus to
> the user bus. With the session bus, gdm was responsible for launching
> dbus-daemon and it could set the DISPLAY and XAUTHORITY environment
> variables for it. With the user bus things work differently, I think.
> gnome-terminal and nautilus are started via dbus activation, which means
> that they inherit their environment from the users dbus-daemon instance and
> without those environment variables set, they can't start under X. You can
> work around this in the "GNOME on Xorg" session by installing xterm (which
> does not use dbus activation), launching it from gnome-shell and then in it
> run "dbus-update-activation-environment DISPLAY XAUTHORITY". This sets the
> environment variables that are used when dbus-daemon is starting processes.
> Now you can start gnome-terminal and nautilus.

OIC.  Although I thought my procedure from comment 31 fixed the issue it seems it only fixes it for that one username, so you have to do that for each username defined on the system.  So I see now that this is more complex than I thought.
Comment 41 Ray Strode [halfline] 2016-02-04 13:14:41 EST
So I hadn't realized we switched to using a user bus, but apparently we did back in august:

http://pkgs.fedoraproject.org/cgit/rpms/dbus.git/commit/?id=ffb87c807674d61b0cf8d04dea3927fe7fb7b46d

The bus is started before the X server now, so we need update the activation environment of the bus with the X server display information.  Should be a small patch to gdm-x-session.  Will look into it.
Comment 42 Ray Strode [halfline] 2016-02-04 13:45:46 EST
should be fixed in tomorrow's rawhide.
Comment 43 Ray Strode [halfline] 2016-02-04 19:00:33 EST
(btw, thanks Sebastian, you hit the nail right on the head with your analysis)
Comment 44 Adam Williamson 2016-02-05 01:32:30 EST
So if this bug indicates the Workstation live session uses X not Wayland, we should probably file a separate bug for that, assuming Wayland is indeed intended to be the default for live sessions? I'm travelling ATM and don't have a live image with me to confirm, though :/
Comment 45 Chris Murphy 2016-02-05 03:21:24 EST
Booting Fedora-Live-Workstation-x86_64-rawhide-20160125.iso, 'journalctl | grep -i wayland' returns no results.
Comment 46 Joachim Frieben 2016-02-05 04:03:11 EST
Updating Fedora-Live-Workstation-x86_64-rawhide-20160131 to gdm-3.19.4.1-3.fc24 before booting into graphical mode has no effect, sorry.
Comment 47 Joachim Frieben 2016-02-05 04:30:13 EST
(In reply to awilliam redhat com from comment #44)
After disabling automatic login and setting a password for user "liveuser", GDM shows "GNOME" (on Wayland) to be the default session of Fedora-Live-Workstation-x86_64-rawhide-20160131. However, even in this case, Xorg instead of Xwayland is being launched unless a successful Xorg session was performed earlier by choosing "GNOME on Xorg" in GDM. Launching a GNOME (on Wayland) session after said "GNOME on Xorg" session, not only gnome-terminal starts up as expected but also Xwayland does.
Comment 48 Adam Williamson 2016-02-05 04:45:19 EST
Thanks Chris and Joachim - I'll file a new bug and CC you.

I'm not totally sure if updating gdm in a live image before starting graphical.target is a sufficient test of the fix for this bug, but Ray would know for sure.
Comment 49 Michael Catanzaro 2016-02-05 09:52:43 EST
Ray, you leak |connection| in the second error path you added, need to free it here:

+        if (reply == NULL) {
+                g_debug ("could not update activation environment: %s", error->message);
+                goto out;
+        }
Comment 51 Joachim Frieben 2016-02-07 12:27 EST
Created attachment 1121941 [details]
GDM debug log file of login procedure for GNOME default session
Comment 52 Joachim Frieben 2016-02-07 12:28 EST
Created attachment 1121942 [details]
GDM debug log file of login procedure for GNOME on Wayland session
Comment 53 Joachim Frieben 2016-02-07 12:42:26 EST
The issue seems to stem from the fact that GDM does not set the session type for a (new) user unless it gets changed. For the default session which is "GNOME (on Wayland)", the debug log file for a new user upon logging in shows an entry:

  "GdmSession: type (null) .."

This probably explains the incomplete initialization of the GNOME environment.
In fact, after setting the session type to "GNOME on Xorg" and back to "GNOME (on Wayland)", logging in from GDM leads to an entry

  "GdmSession: type wayland .." .

Likewise setting the session type from the initial "GNOME (on Wayland)" to "GNOME on Xorg" and logging in, an entry

  "GdmSession: type gnome-xorg .."

appears in GDM's debug log file. In cases 2 and 3, the desktop behaves as expected. in particular, standard GNOME applications like gnome-terminal start up successfully.
Comment 54 Ray Strode [halfline] 2016-02-09 12:02:27 EST
sorry, there were a couple more problems including the problem Joachim found.

Should be set by tomorrow.

Note You need to log in before you can comment on or make changes to this bug.