Bug 1305076 - Regression: quadbuffer stereo support
Regression: quadbuffer stereo support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter (Show other bugs)
7.3
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Owen Taylor
Desktop QE
:
: 1324686 (view as bug list)
Depends On:
Blocks: 1276412 1297830 1313485 1306801 1306802 1364088
  Show dependency treegraph
 
Reported: 2016-02-05 09:34 EST by Owen Taylor
Modified: 2016-11-03 21:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1306801 1306802 (view as bug list)
Environment:
Last Closed: 2016-11-03 21:43:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Owen Taylor 2016-02-05 09:34:34 EST
The support for quadbuffer stereo that was added in RHEL-7.1 (see bug 861507) is not functional in RHEL-7.2; this is because the Mutter patch that was part of this was accidentally dropped in the RHEL-7.2 rebase of GNOME.

To fix this problem, we need to at a minimum: 
 
 Update mutter to include a rebased version of the patch - I've already done the rebase and tested that it works.
 Update clutter - the mutter patch doesn't compile without a small fix to clutter. When the stereo patch for clutter was rebased for RHEL-7.2, the newly added symbols to enable stereo were accidentally not exported from the library.

We may also want to update gnome-shell to pick up the fix for:

 https://bugzilla.gnome.org/show_bug.cgi?id=761566

Without that, the restart of GNOME Shell to enable stereo is not very smooth because maximized windows jump around.
Comment 2 Ray Strode [halfline] 2016-04-22 13:49:00 EDT
*** Bug 1324686 has been marked as a duplicate of this bug. ***
Comment 7 errata-xmlrpc 2016-11-03 21:43:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2258.html

Note You need to log in before you can comment on or make changes to this bug.