Bug 130515 - after an update something most of /dev/
Summary: after an update something most of /dev/
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 130516 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-20 22:47 UTC by Michal Jaegermann
Modified: 2014-03-17 02:47 UTC (History)
2 users (show)

Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 21:51:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2004-08-20 22:47:27 UTC
Description of problem:

After 20040820 update I got a number of weird errors on
startup culminating in X totally locking up machine with
a blank screen.  A closer investigation revealed that most
of my /dev/ is gone.  This is what I see:

# rpm -V dev | grep missing | wc -l 
19162

In whatever is left (not much) all block and character devices
have 600 permissions and this includes things like /dev/null (!!!).
X locks up because nothing exists in /dev/input/ and
/dev/mouse also cannot be found.  Luckily enough was left that
I can still login.

I happen to have udev installed but in /etc/rc.d/rc.sysinit
there is the following code:

if [ -f /etc/sysconfig/udev ];then
        . /etc/sysconfig/udev
fi

if [ "$USE_UDEV" = "yes" -a "$UDEV_RAMFS" = "yes" ]; then
        [ -x /sbin/start_udev ] && /sbin/start_udev
fi

and I do not have /etc/sysconfig/udev at this moment so this
should not do anything.

What is even more weird that x86_64 updated to the same level
is not showing up any symptoms of that sort.  I am somewhat
baffled but something decided to mess up my /dev quite thorougly.
A buggy %post script in some package and not initscripts at all?

Version-Release number of selected component (if applicable):
initscripts-7.64-1

Comment 1 Michal Jaegermann 2004-08-20 22:49:26 UTC
A subject was supposed to say "... something ate most of /dev/".
It seems that this gobbling is contagious.

Comment 2 Michal Jaegermann 2004-08-21 00:01:17 UTC
The next strange thing.  An attempt of recovery by reinstalling
'dev' package brought:
 
Cannot install the dev package: mounted devfs detected.
error: %pre(dev-3.8.3-1) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping dev-3.8.3-1

'devfs' was never in use on a machine in question but this gives
a clue.  This is a bogus message from %pre script in dev and
responsible for that mess is a lack of synchronization between
mkinitrd and initscripts which use different criteria when to
employ 'udev' so I end up with very incomplete udev courtesy
of initrd as there is no followup.

Comment 3 Bill Nottingham 2004-08-21 03:56:19 UTC
There is a fix for the udev start confusion in initscripts-7.65-1.

Comment 4 Bastien Nocera 2004-08-31 02:05:17 UTC
*** Bug 130516 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2005-09-30 21:51:10 UTC
This should be fixed in the final releases of udev-containing releases (such as
FC3/FC4); moreover, there are notes about how to update to udev with yum. Ergo,
closing.


Note You need to log in before you can comment on or make changes to this bug.