Bug 130522 - missing xorg-x11-deprecated-libs.i386
missing xorg-x11-deprecated-libs.i386
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 131144 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-20 19:59 EDT by Thomas Zehetbauer
Modified: 2014-03-16 22:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-06 16:46:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Zehetbauer 2004-08-20 19:59:18 EDT
Mozilla Firefox and I suppose a lot of other programs do no longer
work with current rawhide because xorg-x11-libs does not provide
libXp.so.6 anymore and xorg-x11-deprecated-libs is not available as
i386 package.

/usr/local/lib/firefox/firefox-bin: error while loading shared
libraries: libXp.so.6: cannot open shared object file: No such file or
directory
Comment 1 Mike A. Harris 2004-08-20 21:42:12 EDT
pts/29 mharris@porkchop:i386$ ls -1
xorg-x11-100dpi-fonts-6.7.99.902-1.i386.rpm
xorg-x11-6.7.99.902-1.i386.rpm
xorg-x11-75dpi-fonts-6.7.99.902-1.i386.rpm
xorg-x11-ISO8859-14-100dpi-fonts-6.7.99.902-1.i386.rpm
xorg-x11-ISO8859-14-75dpi-fonts-6.7.99.902-1.i386.rpm
xorg-x11-ISO8859-15-100dpi-fonts-6.7.99.902-1.i386.rpm
xorg-x11-ISO8859-15-75dpi-fonts-6.7.99.902-1.i386.rpm
xorg-x11-ISO8859-2-100dpi-fonts-6.7.99.902-1.i386.rpm
xorg-x11-ISO8859-2-75dpi-fonts-6.7.99.902-1.i386.rpm
xorg-x11-ISO8859-9-100dpi-fonts-6.7.99.902-1.i386.rpm
xorg-x11-ISO8859-9-75dpi-fonts-6.7.99.902-1.i386.rpm
xorg-x11-Mesa-libGL-6.7.99.902-1.i386.rpm
xorg-x11-Mesa-libGLU-6.7.99.902-1.i386.rpm
xorg-x11-Xdmx-6.7.99.902-1.i386.rpm
xorg-x11-Xnest-6.7.99.902-1.i386.rpm
xorg-x11-Xvfb-6.7.99.902-1.i386.rpm
xorg-x11-base-fonts-6.7.99.902-1.i386.rpm
xorg-x11-cyrillic-fonts-6.7.99.902-1.i386.rpm
xorg-x11-deprecated-libs-6.7.99.902-1.i386.rpm
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
xorg-x11-deprecated-libs-devel-6.7.99.902-1.i386.rpm
xorg-x11-devel-6.7.99.902-1.i386.rpm
xorg-x11-doc-6.7.99.902-1.i386.rpm
xorg-x11-font-utils-6.7.99.902-1.i386.rpm
xorg-x11-libs-6.7.99.902-1.i386.rpm
xorg-x11-libs-data-6.7.99.902-1.i386.rpm
xorg-x11-sdk-6.7.99.902-1.i386.rpm
xorg-x11-syriac-fonts-6.7.99.902-1.i386.rpm
xorg-x11-tools-6.7.99.902-1.i386.rpm
xorg-x11-truetype-fonts-6.7.99.902-1.i386.rpm
xorg-x11-twm-6.7.99.902-1.i386.rpm
xorg-x11-xauth-6.7.99.902-1.i386.rpm
xorg-x11-xdm-6.7.99.902-1.i386.rpm
xorg-x11-xfs-6.7.99.902-1.i386.rpm


Closing as "NOTABUG", package exists for i386.
Comment 2 Mike A. Harris 2004-08-20 21:43:20 EDT
$ rpm -qlp xorg-x11-deprecated-libs-6.7.99.902-1.i386.rpm
/usr/X11R6/lib/libXp.so.6
/usr/X11R6/lib/libXp.so.6.2

Comment 3 Thomas Zehetbauer 2004-08-21 05:50:56 EDT
You may have noticed that I filed this bug against the x86_64
architecture; There is no xorg-deprecated-libs-*.i386.rpm at
http://download.fedora.redhat.com/pub/fedora/linux/core/development/x86_64/Fedora/RPMS/
Comment 4 Mike A. Harris 2004-08-21 07:09:43 EDT
This is not an xorg-x11 packaging bug or software bug.

The xorg-x11 package generates a deprecated-libs package on all
architectures.  What's included in the ftp server's directories, is
not something affected by the xorg-x11 src.rpm, nor the binaries
that are generated.  The i386 directory should have the file you
are looking for.

Comment 5 Thomas Zehetbauer 2004-08-21 07:30:28 EDT
Of course I can use the rpm from the i386 directory but as this
package is a compatibility complement to the xorg-x11-libs rpm which
is available as both x86_64 and i386 package I feel that the i386
version of xorg-x11-deprecated-libs should be included in the x86_64
tree as well.
Comment 6 Mike A. Harris 2004-08-21 07:46:38 EDT
Reassigning to "distribution" component, not an xorg-x11 package
problem.
Comment 7 Bill Nottingham 2004-08-27 18:56:49 EDT
*** Bug 131144 has been marked as a duplicate of this bug. ***
Comment 8 Erich Hoover 2004-09-04 22:09:50 EDT
The i386 package is now in the x86-64 tree.

Note You need to log in before you can comment on or make changes to this bug.