Bug 131144 - i386 libXp.so.6 missing
Summary: i386 libXp.so.6 missing
Status: CLOSED DUPLICATE of bug 130522
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: 3
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-27 21:54 UTC by Erich Hoover
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Erich Hoover 2004-08-27 21:54:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7)
Gecko/20040629 Firefox/0.9.1

Description of problem:
The xorg deprecated libs do not have an i386 equivalent package
(xorg-x11-deprecated-libs-6.7.99.902-8.x86_64.rpm).  So, when
libXp.so.6 was moved to the deprecated library package functionality
of i386 programs (such as Mozilla Firefox) got broken.

Version-Release number of selected component (if applicable):
xorg-x11-6.7.99.902-8

How reproducible:
Always

Steps to Reproduce:
1. Install FC3T1 and upgrade to latest packages
2. Install Mozilla Firefox (32-bit Official Binary)
3. Run Mozilla Firefox
    

Actual Results:  error while loading shared libraries: libXp.so.6:
cannot open shared object file: No such file or directory


Expected Results:  Mozilla Firefox runs fine

Additional info:

This problem can be avoided by installing your own 64-bit binaries,
but then plugins that are only available for 32-bit processors (Flash,
Java, etc.) will not work.

Comment 1 Bill Nottingham 2004-08-27 22:56:46 UTC

*** This bug has been marked as a duplicate of 130522 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:05:20 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.