Bug 1305423 - Unable to recognize the active view for graph, hybrid and tabular view
Unable to recognize the active view for graph, hybrid and tabular view
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Martin Povolny
Aziza Karol
configuration:view:ui
: ZStream
Depends On:
Blocks: 1305668
  Show dependency treegraph
 
Reported: 2016-02-08 02:32 EST by Aziza Karol
Modified: 2016-06-29 11:36 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1305668 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:36:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
akarol: automate_bug+


Attachments (Terms of Use)
with font icons (46.24 KB, image/png)
2016-02-09 08:44 EST, Eric Winchell
no flags Details

  None (edit)
Description Aziza Karol 2016-02-08 02:32:50 EST
Created attachment 1122078 [details]
snapshot

Description of problem:


Version-Release number of selected component (if applicable):
5.5.2.4.20160127105142_395c086

How reproducible:
100%

Steps to Reproduce:
1.Navigate to cloud intelligence->reports
2.Generate a report for Virtual infrastructure platforms in Configuration Management-> Hosts
3.After the report is generated click on graph view , hybrid view or tabular view

Actual results:
Unable to recognize which one is active when you click on any view.

Expected results:
color should be changed for the active one as it is done in other pages.


Additional info:
Comment 3 Eric Winchell 2016-02-09 08:44 EST
Created attachment 1122425 [details]
with font icons
Comment 6 CFME Bot 2016-04-21 13:05:39 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/0a78dfbcd086577c0f9c6174d1a195629cab50d6

commit 0a78dfbcd086577c0f9c6174d1a195629cab50d6
Author:     Martin Povolny <mpovolny@redhat.com>
AuthorDate: Wed Apr 20 16:01:15 2016 +0200
Commit:     Martin Povolny <mpovolny@redhat.com>
CommitDate: Wed Apr 20 20:33:49 2016 +0200

    Fix styling of two-state view buttons.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1305423
    https://bugzilla.redhat.com/show_bug.cgi?id=1305668
    
    There are 2 ways view buttons states are rendered:
    a) enabled/disabled
    b) two state selected/not selected
    
    This should be unified in a separate PR.

 app/helpers/application_helper/toolbar_builder.rb |  2 +-
 app/helpers/toolbar_helper.rb                     | 20 ++++++++++++++++----
 2 files changed, 17 insertions(+), 5 deletions(-)
Comment 8 Aziza Karol 2016-05-23 02:55:12 EDT
Able to recognize the active view for graph, hybrid and tabular view.

Verified:
5.6.0.7-beta2.6.20160516171555_b1be31f
Comment 9 CFME Bot 2016-06-13 16:12:39 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=859831b7c7d0f601f8418b1aa3a33d563f609aec

commit 859831b7c7d0f601f8418b1aa3a33d563f609aec
Author:     Martin Povolny <mpovolny@redhat.com>
AuthorDate: Wed Apr 20 16:01:15 2016 +0200
Commit:     Martin Povolny <mpovolny@redhat.com>
CommitDate: Wed May 18 13:46:52 2016 +0200

    Fix styling of two-state view buttons.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1305423
    https://bugzilla.redhat.com/show_bug.cgi?id=1305668
    
    There are 2 ways view buttons states are rendered:
    a) enabled/disabled
    b) two state selected/not selected
    
    This should be unified in a separate PR.

 app/helpers/toolbar_helper.rb | 20 ++++++++++++++++----
 1 file changed, 16 insertions(+), 4 deletions(-)
Comment 11 errata-xmlrpc 2016-06-29 11:36:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.