Bug 1305668 - Unable to recognize the active view for graph, hybrid and tabular view
Unable to recognize the active view for graph, hybrid and tabular view
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.5
Assigned To: Martin Povolny
Aziza Karol
: ZStream
Depends On: 1305423
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 15:43 EST by John Prause
Modified: 2016-07-26 11:31 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.5.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1305423
Environment:
Last Closed: 2016-07-26 11:31:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 15:28:27 EDT

  None (edit)
Comment 4 CFME Bot 2016-04-21 13:05:43 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/0a78dfbcd086577c0f9c6174d1a195629cab50d6

commit 0a78dfbcd086577c0f9c6174d1a195629cab50d6
Author:     Martin Povolny <mpovolny@redhat.com>
AuthorDate: Wed Apr 20 16:01:15 2016 +0200
Commit:     Martin Povolny <mpovolny@redhat.com>
CommitDate: Wed Apr 20 20:33:49 2016 +0200

    Fix styling of two-state view buttons.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1305423
    https://bugzilla.redhat.com/show_bug.cgi?id=1305668
    
    There are 2 ways view buttons states are rendered:
    a) enabled/disabled
    b) two state selected/not selected
    
    This should be unified in a separate PR.

 app/helpers/application_helper/toolbar_builder.rb |  2 +-
 app/helpers/toolbar_helper.rb                     | 20 ++++++++++++++++----
 2 files changed, 17 insertions(+), 5 deletions(-)
Comment 7 CFME Bot 2016-06-13 16:12:29 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=aaa8ae4e999969a3b58ddc114e0a999e3507fdb4

commit aaa8ae4e999969a3b58ddc114e0a999e3507fdb4
Author:     Martin Povolny <mpovolny@redhat.com>
AuthorDate: Tue Apr 26 10:33:36 2016 +0200
Commit:     Martin Povolny <mpovolny@redhat.com>
CommitDate: Wed May 18 13:46:52 2016 +0200

    Backport report results toolbar icon changes.
    
    Taken from a2b2c3cccb1a293186eb33733770f2fd5feb7f0f to get
    enabled/disabled state for the button.
    
    Specifix 5.5.z fix for
    https://bugzilla.redhat.com/show_bug.cgi?id=1305668

 product/toolbars/report_view_tb.yaml | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
Comment 8 CFME Bot 2016-06-13 16:12:34 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=5b7a0129d0e5b9bdc982c1e14ad4266a4c80928b

commit 5b7a0129d0e5b9bdc982c1e14ad4266a4c80928b
Merge: a39de4d aaa8ae4
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Jun 13 16:11:15 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Jun 13 16:11:15 2016 -0400

    Merge branch 'bz1305668' into '5.5.z'
    
    Report view mode button styling backport
    
    This was not a clean backport at all. @dclarizi, @ewinchel : please review
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1305668
    
    See merge request !911

 app/helpers/toolbar_helper.rb        | 20 ++++++++++++++++----
 product/toolbars/report_view_tb.yaml |  6 +++---
 2 files changed, 19 insertions(+), 7 deletions(-)
Comment 9 CFME Bot 2016-06-13 16:12:44 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=859831b7c7d0f601f8418b1aa3a33d563f609aec

commit 859831b7c7d0f601f8418b1aa3a33d563f609aec
Author:     Martin Povolny <mpovolny@redhat.com>
AuthorDate: Wed Apr 20 16:01:15 2016 +0200
Commit:     Martin Povolny <mpovolny@redhat.com>
CommitDate: Wed May 18 13:46:52 2016 +0200

    Fix styling of two-state view buttons.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1305423
    https://bugzilla.redhat.com/show_bug.cgi?id=1305668
    
    There are 2 ways view buttons states are rendered:
    a) enabled/disabled
    b) two state selected/not selected
    
    This should be unified in a separate PR.

 app/helpers/toolbar_helper.rb | 20 ++++++++++++++++----
 1 file changed, 16 insertions(+), 4 deletions(-)
Comment 11 Aziza Karol 2016-07-11 01:33:07 EDT
Able to recognize the active view for graph, hybrid and tabular view.

Verified:
5.5.5.0.20160628144838_629f93b
Comment 13 errata-xmlrpc 2016-07-26 11:31:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html

Note You need to log in before you can comment on or make changes to this bug.