Bug 1305453 - [CSB] Sound system doesn't handle properly bluetooth headset's microphone
[CSB] Sound system doesn't handle properly bluetooth headset's microphone
Status: NEW
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pulseaudio (Show other bugs)
7.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Wim Taymans
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-08 04:52 EST by Eric Lavarde
Modified: 2017-05-29 04:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Lavarde 2016-02-08 04:52:45 EST
Description of problem:
https://bugzilla.redhat.com/show_bug.cgi?id=1179876 was created and marked as solved, and indeed with CSB / RHEL 7.2 the binding of the headset works better, but still not good enough for daily use.

Version-Release number of selected component (if applicable):
$ rpm -qa | grep bluetooth
gnome-bluetooth-libs-3.14.1-1.el7.x86_64
gnome-bluetooth-3.14.1-1.el7.x86_64
NetworkManager-bluetooth-1.0.6-27.el7.x86_64
pulseaudio-module-bluetooth-6.0-7.el7.x86_64

How reproducible:
Always


Steps to Reproduce:

1. Pair your bluetooth headset (Sennheiser EZX 80 in my case)
2. Connect it
3. Open the sound settings and test your headset

Actual results:

A. Output tab shows my bluetooth headset with two profiles [so far so good]:
- Headset Head Unit (HSP/HFP)
- High Fidelity Playback (A2DP Sink)
B. but the HSP/HFP is mono and the [Test Speakers] test doesn't produce any sound (I hear sometimes a "clack" but nothing more), I need to select A2DP, which appears in stereo even though my headset has only one ear-plug, but the test works, I hear right and left both on my one ear.
C. The Input tab shows also my Headset [also good]
D. If I click on it, though, the dialog continues to show the sound level of my internal microphone (the Built-In Audio).
E. If I click back on Internal Microphone and then again on Headset, the sound level stops reacting to my words (and in the "Output" tab, the sound has jumped back to Built-in Audio).
F. If I click on Output->Headset with HSP/HFP profile, then both output and input the headset don't work (but the Output tab doesn't jump back to Built-In Audio while I change the Input source).

Expected results:

I can hear and speak through my Bluetooth headset without issue.

Additional info:

I suspect that the issue is that the A2DP profile doesn't have a microphone foreseen and that the HSP/HFP isn't properly supported by RHEL (yet). It would be great to have this properly supported (and tested before release; if you've tested it, please tell me your model).

Laptop is a Lenovo T430s.

$ dmesg | grep -i bluetooth
[   20.377757] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
[   22.023029] Bluetooth: Core ver 2.16
[   22.023191] Bluetooth: HCI device and connection manager initialized
[   22.023199] Bluetooth: HCI socket layer initialized
[   22.023203] Bluetooth: L2CAP socket layer initialized
[   22.023209] Bluetooth: SCO socket layer initialized
[   23.326385] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   23.326388] Bluetooth: BNEP filters: protocol multicast
[   23.326395] Bluetooth: BNEP socket layer initialized
[   59.692827] Bluetooth: RFCOMM TTY layer initialized
[   59.692838] Bluetooth: RFCOMM socket layer initialized
[   59.692927] Bluetooth: RFCOMM ver 1.11
Comment 2 Oliver Haessler 2016-04-22 07:28:55 EDT
Do we have any news on this bugzilla bug?
Comment 3 Bastien Nocera 2016-04-25 11:23:01 EDT
PulseAudio handles the actual talking to the devices, and most of the weird behaviour will be down to the PulseAudio <-> Bluetooth headset communication not working properly.
Comment 4 Chuck Copello 2016-07-28 10:41:29 EDT
Is there an ETA for getting this fix? I'm using a Lenovo X1 Carbon, RHEL 7.2 (CSB), Jawbone ICON HD. It connects, but the audio goes between laggy and non-existent.
Comment 5 Oliver Haessler 2016-09-01 10:24:13 EDT
Chuck, is the sound getting better for you if you switch the Profile in the sound settings from HSP/HFP to A2DP? (or did you meant audio from your microphone?).
Comment 6 Chuck Copello 2016-09-01 10:41:19 EDT
Hi Oliver, 

My biggest challenge is getting the pairing and connection to stay active. Last week it actually paired, and stayed connected long enough to play music through it. Didn't experiment with microphone. Today I'm trying to connect it, and it's cycling through "Disconnected" and "Connected" (for maybe 1 sec).
Comment 7 Chuck Copello 2016-09-20 15:07:04 EDT
Recorded a video on my phone showing the pairing / not paired switching => https://drive.google.com/open?id=0B5ssspNAkSvTY0s4V0tSSUFfZFk

Since this isn't an audio profile issue and an actual connection issue, should I enter a new BZ (or find an existing BZ focusing on connecting)?
Comment 8 Eric Lavarde 2016-09-21 10:21:45 EDT
@Chuck, I don't have any issue with pairing, so it sounds like a different case.

BTW, on my new laptop, T460s, same software stand (see below), step B  with HSP/HFP profile is still mono but there is white noise instead of only silence. Not sure this is an improvement :-/

$ rpm -qa | grep bluetooth
pulseaudio-module-bluetooth-6.0-7.el7.x86_64
gnome-bluetooth-3.14.1-1.el7.x86_64
gnome-bluetooth-libs-3.14.1-1.el7.x86_64
Comment 9 Chuck Copello 2016-09-21 14:20:13 EDT
Hi Eric,

I have the same as you. I'll open a new BZ.
Comment 10 Chuck Copello 2016-09-21 14:32:34 EDT
I opened up new BZ https://bugzilla.redhat.com/show_bug.cgi?id=1378185 for my pairing issues.
Comment 11 Chuck Copello 2016-12-13 19:58:35 EST
Back to the party specifically for microphone issue. Same CSB laptop, RHEL 7.3. New PowerBeats Wireless headset. When the PowerBeats pair, it doesn't recognize that the headset has a microphone. I only have internal microphone as my mic option. In Red Hat Tower, my laptop is toward the back of my desk, I sit directly under an air vent, and the internal mic is rendered useless. I bought the headset so I could use them for hours of Bluejeans calls a week without being wired. 

Is the microphone of a Bluetooth headset supported? Doesn't seem like this would be a brand-specific issue.
Comment 12 Eric Lavarde 2017-03-03 05:23:26 EST
I can reproduce the issue with Fedora 25 under Gnome. Should I create a separate report, or how best to handle (I don't see a cloning button)?

$ rpm -qa | grep blue
gnome-bluetooth-libs-3.20.1-1.fc25.x86_64
NetworkManager-bluetooth-1.4.4-3.fc25.x86_64
bluez-obexd-5.43-2.fc25.x86_64
bluez-5.43-2.fc25.x86_64
pulseaudio-module-bluetooth-10.0-2.fc25.x86_64
gnome-bluetooth-3.20.1-1.fc25.x86_64
bluez-cups-5.43-2.fc25.x86_64
bluez-libs-5.43-2.fc25.x86_64
Comment 13 W. de Heiden 2017-03-28 13:18:19 EDT
Suffering this one on Fedora 25 as wel using a Philips SHB8850NC headphone, in particular using the Bluejeans software.
Comment 14 Gabriel 2017-04-12 20:21:39 EDT
I'm facing the same issue under on a Lenovo T460 and RHEL 7.3.

$ rpm -qa | grep bluetooth
gnome-bluetooth-3.14.1-1.el7.x86_64
pulseaudio-module-bluetooth-6.0-8.el7.x86_64
gnome-bluetooth-libs-3.14.1-1.el7.x86_64

$ dmesg | grep Bluetooth
[   15.319094] Bluetooth: Core ver 2.21
[   15.319110] Bluetooth: HCI device and connection manager initialized
[   15.319114] Bluetooth: HCI socket layer initialized
[   15.319116] Bluetooth: L2CAP socket layer initialized
[   15.319121] Bluetooth: SCO socket layer initialized
[   15.337397] Bluetooth: hci0: Firmware revision 0.0 build 30 week 18 2016
[   16.887770] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   16.887773] Bluetooth: BNEP filters: protocol multicast
[   16.887778] Bluetooth: BNEP socket layer initialized
[   36.300269] Bluetooth: RFCOMM TTY layer initialized
[   36.300278] Bluetooth: RFCOMM socket layer initialized
[   36.300372] Bluetooth: RFCOMM ver 1.11


Headset is a Logitech H800 and the pairing works smoothly. I can also see the HSP/HFP profile. However, the mic is not recognized.

gpborges@gpborges:~$ bluetoothctl
[NEW] Controller A4:34:D9:83:10:9D gpborges.br.ibm.com [default]
[NEW] Device 00:0D:44:DE:83:86 H800 Logitech Headset
[H800 Logitech Headset]# info 
Device 00:0D:44:DE:83:86
	Name: H800 Logitech Headset
	Alias: H800 Logitech Headset
	Class: 0x240404
	Icon: audio-card
	Paired: yes
	Trusted: yes
	Blocked: no
	Connected: yes
	LegacyPairing: no
	UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
	UUID: Advanced Audio Distribu.. (0000110d-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
	UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)
[H800 Logitech Headset]# 

It would be great if we see this bug fixed.

Thanks in advance!
Comment 15 Christian Kellner 2017-04-13 03:29:43 EDT
This seems like a combination of different issues, I strongly suspect bugs.freedesktop.org#90027 to be the cause of problem B) in the first comment. I am personally also seeing at least E) present on Fedora 25. I will have a look at these issues.
Comment 16 Gabriel 2017-05-09 16:02:29 EDT
Folks, were anyone able to make any progress on this investigation? Thanks in advance!
Comment 17 Christian Kellner 2017-05-10 03:04:57 EDT
The problem that HFP/HSP does not work seems to be a kernel issue that has been fixed in 4.11 (at least for my combination of hardware involved). Will try different headsets to confirm. Some of the UI issues still remain though.
Comment 18 Gabriel 2017-05-26 17:41:24 EDT
I just installed kernel 4.11.3 (4.11.3-1.el7.elrepo.x86_64) in my RHEL 7.3 and the mic is still not working for my Logitech H800. :-( I am using Cinnamon and I used bluebuerry (GUI) to pair it. Same thing as with kernel 3.10. It lists the HFP but no mic is displayed to be selected. Tried from default sound settings and also pauvcontrol.

Did you do anything specific to get your setup working with kernel 4.11?

Thx.
Comment 19 Eric Lavarde 2017-05-29 04:05:29 EDT
I wanted to inform you that I've got now the sound working with my bluetooth headset (Sennheiser EZX 80) since a little while on Fedora 25 with kernel 4.10. HFP is correctly recognized and doesn't jump, I can hear and talk, e.g. with cheese or BlueJeans. The only small glitch remaining is that the sound test in the sound settings doesn't work properly (only white noise).

At the same time where the kernel was upgraded from 4.9 to 4.10, bluez was upgraded from 5.43 to 5.44:

Transaction ID : 44
Begin time     : Fri Mar 31 10:33:33 2017
[...]
    Upgraded bluez-5.43-2.fc25.x86_64                               @updates
    Upgrade        5.44-1.fc25.x86_64                               @updates
    Upgraded bluez-cups-5.43-2.fc25.x86_64                          @updates
    Upgrade             5.44-1.fc25.x86_64                          @updates
    Upgraded bluez-libs-5.43-2.fc25.x86_64                          @updates
    Upgrade             5.44-1.fc25.x86_64                          @updates
    Upgraded bluez-obexd-5.43-2.fc25.x86_64                         @updates
    Upgrade              5.44-1.fc25.x86_64                         @updates
[...]
    Install  kernel-4.10.5-200.fc25.x86_64                          @updates
    Erase    kernel-4.9.13-200.fc25.x86_64                          @updates
    Install  kernel-core-4.10.5-200.fc25.x86_64                     @updates
    Erase    kernel-core-4.9.13-200.fc25.x86_64                     @updates
    Upgrade  kernel-headers-4.10.5-200.fc25.x86_64                  @updates
    Upgraded kernel-headers-4.9.14-200.fc25.x86_64                  @updates
    Install  kernel-modules-4.10.5-200.fc25.x86_64                  @updates
    Erase    kernel-modules-4.9.13-200.fc25.x86_64                  @updates
    Upgrade  kernel-tools-4.10.5-200.fc25.x86_64                    @updates
    Upgraded kernel-tools-4.9.14-200.fc25.x86_64                    @updates
    Upgrade  kernel-tools-libs-4.10.5-200.fc25.x86_64               @updates
    Upgraded kernel-tools-libs-4.9.14-200.fc25.x86_64               @updates
[...]

Sadly, I didn't pay exactly attention when it got better, but the time stamp makes roughly sense. I hope it helps to find the right thing to backport.
Comment 20 Christian Kellner 2017-05-29 04:48:25 EDT
(In reply to Eric Lavarde from comment #19)
> I wanted to inform you that I've got now the sound working with my bluetooth
> headset (Sennheiser EZX 80) since a little while on Fedora 25 with kernel
> 4.10. HFP is correctly recognized and doesn't jump, I can hear and talk,
> e.g. with cheese or BlueJeans. 
Glad to hear it!

> The only small glitch remaining is that the
> sound test in the sound settings doesn't work properly (only white noise).
Ironically, that is work as expected: the test sound for the mono speaker is static noise. I think that is quite confusing and therefore I filed a bug about it: https://bugs.freedesktop.org/show_bug.cgi?id=100977

> At the same time where the kernel was upgraded from 4.9 to 4.10, bluez was
> upgraded from 5.43 to 5.44:
For my experiments it seems you need to have both updates. I was planning to nail this down but then got busy with other things. Thanks very much for your input, very much appreciated.

Note You need to log in before you can comment on or make changes to this bug.