Bug 1305456 - Errors seen in cli.log, while executing the command 'gluster snapshot info --xml'
Errors seen in cli.log, while executing the command 'gluster snapshot info --...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: snapshot (Show other bugs)
3.1
x86_64 Linux
unspecified Severity medium
: ---
: RHGS 3.1.3
Assigned To: Avra Sengupta
Anil Shah
snapshot xml
: Patch, Triaged, ZStream
Depends On:
Blocks: 1299184 1316819 1317363
  Show dependency treegraph
 
Reported: 2016-02-08 05:06 EST by SATHEESARAN
Modified: 2016-09-17 08:53 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1316819 (view as bug list)
Environment:
Last Closed: 2016-06-23 01:06:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SATHEESARAN 2016-02-08 05:06:48 EST
Description of problem:
-----------------------
Error messages are seen in the cli.log, while executing 'gluster snapshot info --xml'

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS 3.1.2 nightly ( glusterfs-3.7.5-19.el7rhgs )

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Execute 'gluster snapshot info --xml'

Actual results:
---------------
Error messages seen in cli.log

Expected results:
-----------------
There shouldn't be any errors seen

Additional info:
----------------
Execution ' gluster snapshot info --xml' in one of the RHGS node triggers the following error in cli.log

<snip>
[2016-02-08 15:24:27.293580] I [cli.c:721:main] 0-cli: Started running gluster with version 3.7.5
[2016-02-08 15:24:27.400471] I [MSGID: 101190] [event-epoll.c:632:event_dispatch_epoll_worker] 0-epoll: Started thread with index 1
[2016-02-08 15:24:27.400634] I [socket.c:2355:socket_event_handler] 0-transport: disconnecting now
[2016-02-08 15:24:27.400865] E [cli-xml-output.c:5996:cli_xml_snapshot_begin_composite_op] 0-cli: Failed to get sub-cmd
[2016-02-08 15:24:27.403990] E [cli-xml-output.c:6041:cli_xml_snapshot_end_composite_op] 0-cli: Failed to get sub-cmd
[2016-02-08 15:24:27.404081] I [input.c:36:cli_batch] 0-: Exiting with: 0
</snip> 

Consequences
-------------
When RHGS nodes are managed with RHGS-C or RHEVM, the engine issues 'gluster snapshot info --xml' with periodic interval, which triggers lots of such errors in cli.log
Comment 1 SATHEESARAN 2016-02-08 05:27:37 EST
Moving the component to snapshot as the issue is with getting xml output of snap info
Comment 3 Avra Sengupta 2016-03-11 03:35:00 EST
Master URL: http://review.gluster.org/#/c/13677/ (IN REVIEW)
Comment 4 Avra Sengupta 2016-03-14 02:22:44 EDT
Master URL: http://review.gluster.org/#/c/13677/ (MERGED)
Release 3.7 URL: http://review.gluster.org/#/c/13691/ (IN REVIEW)
Comment 7 Anil Shah 2016-03-30 05:40:27 EDT
Seeing error logs again while executing gluster snapshot info --xml on build glusterfs-3.7.9-1.el7rhgs.x86_64.

Moving bug to assigned state.



[2016-03-30 14:36:19.301603] I [cli.c:721:main] 0-cli: Started running gluster with version 3.7.9
[2016-03-30 14:36:19.441205] I [MSGID: 101190] [event-epoll.c:632:event_dispatch_epoll_worker] 0-epoll: Started thread with index 1
[2016-03-30 14:36:19.441402] I [socket.c:2356:socket_event_handler] 0-transport: disconnecting now
[2016-03-30 14:36:19.441562] E [cli-xml-output.c:6040:cli_xml_snapshot_begin_composite_op] 0-cli: Failed to get sub-cmd
[2016-03-30 14:36:19.445338] E [cli-xml-output.c:6085:cli_xml_snapshot_end_composite_op] 0-cli: Failed to get sub-cmd
[2016-03-30 14:36:19.445383] I [input.c:36:cli_batch] 0-: Exiting with: 0
Comment 8 Avra Sengupta 2016-04-05 04:29:55 EDT
Failed QA because the build got spawned right before this patch got merged into the 3.1.3 branch. Moving it to POST.
Comment 9 Anil Shah 2016-04-25 09:13:57 EDT
Not seeing error logs after executing gluster snapshot info --xml command.
Bug verified on build  glusterfs-3.7.9-2.el7rhgs.x86_64
Comment 11 errata-xmlrpc 2016-06-23 01:06:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240

Note You need to log in before you can comment on or make changes to this bug.