Bug 1316819 - Errors seen in cli.log, while executing the command 'gluster snapshot info --xml'
Errors seen in cli.log, while executing the command 'gluster snapshot info --...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
mainline
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Avra Sengupta
snapshot xml
: Triaged, ZStream
Depends On: 1305456
Blocks: 1317363
  Show dependency treegraph
 
Reported: 2016-03-11 03:33 EST by Avra Sengupta
Modified: 2016-06-16 10:00 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1305456
: 1317363 (view as bug list)
Environment:
Last Closed: 2016-06-16 10:00:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-03-11 03:34:16 EST
REVIEW: http://review.gluster.org/13677 (snapshot/cli: Keep the dict keys uniform) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 2 Vijay Bellur 2016-03-14 02:19:12 EDT
COMMIT: http://review.gluster.org/13677 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 1af963dc753d97efb3cbe3e5179a2148c41c9a7d
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Fri Mar 11 14:01:31 2016 +0530

    snapshot/cli: Keep the dict keys uniform
    
    snapshot info was using a different dictionary key
    as compared to other snapshot commands. This was
    throwing a recurring error log in cli.log
    
    Change-Id: I9eb9a4541c10a45ec7673a23c89c85a7dce9f3ec
    BUG: 1316819
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/13677
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
Comment 3 Niels de Vos 2016-06-16 10:00:28 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.