Bug 130575 - /sbin/ifup kills a name resolution on DHCP connections
/sbin/ifup kills a name resolution on DHCP connections
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 130592 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-21 21:20 EDT by Michal Jaegermann
Modified: 2014-03-16 22:47 EDT (History)
4 users (show)

See Also:
Fixed In Version: initscripts-7.67
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 15:17:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix to change_resolv_conf() in network-functions for initscripts-7.66-1 (583 bytes, patch)
2004-08-22 12:07 EDT, Kaj J. Niemi
no flags Details | Diff
fix to change_resolv_conf() in network-functions for initscripts-7.66-1, removed debug echoing (571 bytes, patch)
2004-08-22 12:08 EDT, Kaj J. Niemi
no flags Details | Diff

  None (edit)
Description Michal Jaegermann 2004-08-21 21:20:04 EDT
Description of problem:

I configure my eth1 interfaces (on different machines) with DHCP
and I have 'PEERDNS=yes' for good reasons.  Suddenly after
'ifup eth1' my /etc/resolv.conf has a legth 1 with only a newline
character in it.  Obviously many other things are immediately
affected.  That happened after the last series of updates.
This despite of that detail that in /var/lib/dhcp/dhclient-eth1.leases
I still have:


lease {
  interface "eth1";
.......
  option domain-name-servers aaa.bbb.cc.ddd;
  option dhcp-server-identifier aaa.bbb.cc.ddd;
.....
}

which is indeed absolutely correct.

Programs from 'dhclient' package do not seem to responsible
for that trouble as they were installed on "Wed 18 Aug 2004"
(although I would not absolutely swear; I had a number of
other "surprises" recently and possibly missed when the problem
started).

Version-Release number of selected component (if applicable):
initscripts-7.66-1

How reproducible:
Always
Comment 1 Kaj J. Niemi 2004-08-22 11:50:13 EDT
L
Comment 2 Kaj J. Niemi 2004-08-22 12:07:01 EDT
Created attachment 102968 [details]
fix to change_resolv_conf() in network-functions for initscripts-7.66-1
Comment 3 Kaj J. Niemi 2004-08-22 12:08:34 EDT
Created attachment 102969 [details]
fix to change_resolv_conf() in network-functions for initscripts-7.66-1, removed debug echoing
Comment 4 Michal Jaegermann 2004-08-22 13:50:53 EDT
After the patch above I got my resolv.conf into a desired state again.
Comment 5 Bill Nottingham 2004-08-23 15:12:13 EDT
*** Bug 130592 has been marked as a duplicate of this bug. ***
Comment 6 Jason Vas Dias 2004-08-23 15:15:09 EDT
This is fixed in initscripts-7.67 .

Note You need to log in before you can comment on or make changes to this bug.