Bug 130592 - wireless dns settings lost - initscripts 7.66
wireless dns settings lost - initscripts 7.66
Status: CLOSED DUPLICATE of bug 130575
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2004-08-22 10:31 EDT by Sammy
Modified: 2014-03-16 22:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:05:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sammy 2004-08-22 10:31:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux; X11; en_US, en) (KHTML, like Gecko)

Description of problem:
I have two interfaces on my notebook, and eth0 for direct ethernet 
connection and eth1 for wireless. After yesterday's update/reboot
I have lost my dns resolving capability. I could still connect to sites
defined in /etc/hosts file bur not others. I presume initscripts was
the problem since the latest changes involved something with
resolv.conf file, which is empty in my case.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.update to initscripts-7.66-1
2.restart computer

Additional info:
Comment 1 Kaj J. Niemi 2004-08-22 11:50:09 EDT
Looks like a duplicate of bug #130592.
Comment 2 John Reiser 2004-08-22 23:06:49 EDT
My /etc/resolv.conf became one blank line only, instead of two lines
of "nameserver xx.yy.zz.ww" furnished by a NetGear RP614v2 NAT box
acting as DHCP server.  This happens with every boot using
initscripts-7.66-1, under both kernel-2.6.8-1.526 and kernel-2.6.8-1.524.

I have two wired interfaces: eth0 is a sis900 in motherboard chipseg,
eth1 is a e100 add-in PCI card.  [Upon initial FC3T1 installation,
anaconda+kudzu put the cards in the other order, but I switched them
because I wanted the same order as the other 5 Linux systems in this
multi-boot box.]  Both kernel modules got loaded automatically:
alias eth0 sis900
alias eth1 e100

-----/sbin/lsmod | egrep 'e100|sis'
e100                   34245  0
mii                     3777  1 e100
sis900                 15941  0

Current configuration uses eth0, and does not use eth1:
-----/sbin/ifconfig -a
eth0      Link encap:Ethernet  HWaddr yy.yy.yy.yy.yy.yy
          inet addr:  Bcast:  Mask:
          inet6 addr: <private> Scope:Link
          RX packets:544 errors:0 dropped:0 overruns:0 frame:0
          TX packets:436 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:552317 (539.3 Kb)  TX bytes:76086 (74.3 Kb)
          Interrupt:12 Base address:0xd400
eth1      Link encap:Ethernet  HWaddr xx.xx.xx.xx.xx.xx
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

[rest snipped]

If I put the correct 'nameserver' lines into /etc/resolv.conf, then I
can ping external sites by DNS name.  Otherwise I must use numerical
IP4 addresses only.  I have dhclient-3.0.1-7 installed.

The commonality with the original poster is two ethernet interfaces,
and an empty /etc/resolv.conf file after booting with initscripts-7.66-1.

Comment 3 Kaj J. Niemi 2004-08-23 08:38:00 EDT
Try applying the patch from bug #130575.
Comment 4 Bill Nottingham 2004-08-23 15:12:02 EDT

*** This bug has been marked as a duplicate of 130575 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:05:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.