Bug 1305836 - DHT: Take blocking locks while renaming files
Summary: DHT: Take blocking locks while renaming files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribute
Version: rhgs-3.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: RHGS 3.1.3
Assignee: Sakshi
QA Contact: krishnaram Karthick
URL:
Whiteboard:
Depends On: 1304966 1310544
Blocks: 1299184
TreeView+ depends on / blocked
 
Reported: 2016-02-09 11:29 UTC by Rahul Hinduja
Modified: 2016-08-01 01:22 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.9-1
Doc Type: Bug Fix
Doc Text:
File renaming operations took non-blocking locks, which meant that they could fail with EBUSY or ESTALE errors when other rename or rebalance operations were in progress. This could lead to a lack of application continuity when the file renaming operation did not succeed. Blocking locks are now used for file renaming operations, so that file operations are blocked until the lock releases. When the file renaming operation is granted the lock, the application continues with the renaming operation, avoiding applicaton continuity problems.
Clone Of: 1304966
Environment:
Last Closed: 2016-06-23 05:07:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1240 0 normal SHIPPED_LIVE Red Hat Gluster Storage 3.1 Update 3 2016-06-23 08:51:28 UTC

Description Rahul Hinduja 2016-02-09 11:29:15 UTC
+++ This bug was initially created as a clone of Bug #1304966 +++

Description of problem:
DHT takes non-blocking locks while renaming files. During parallel renames and parallel rebalance and rename clients might fail with EBUSY or ESTALE errors. Hence to avoid application discontinuity renaming of files must take blocking locks.

Hence it is better to take blocking locks for renaming files.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-02-05 04:26:34 EST ---

REVIEW: http://review.gluster.org/13366 (dht: file rename must take blocking inode locks) posted (#1) for review on master by Sakshi Bansal

Comment 6 krishnaram Karthick 2016-05-10 06:20:49 UTC
Verified the bug in build - glusterfs-server-3.7.9-2.el7rhgs.x86_64. 

Performed renames and lookup from different mount point on multiple dirs, no issues were seen with renames, no error messages were seen in the logs. renames completed successfully.

Comment 13 errata-xmlrpc 2016-06-23 05:07:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240


Note You need to log in before you can comment on or make changes to this bug.