Bug 1305839 - Wrong interpretation of disk size in gverify.sh script
Wrong interpretation of disk size in gverify.sh script
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Saravanakumar
:
Depends On:
Blocks: 1315170
  Show dependency treegraph
 
Reported: 2016-02-09 06:32 EST by Saravanakumar
Modified: 2016-06-16 09:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1315170 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:57:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saravanakumar 2016-02-09 06:32:00 EST
Description of problem:

Run gverify script as below:
#/usr/local/libexec/glusterfs/gverify.sh  tv1 root gfvm4 tv2 22 /tmp/test.log 

Testing_Passwordless_SSH
/usr/local/libexec/glusterfs/gverify.sh: line 206: [: 1-blocks: integer expression expected

Version-Release number of selected component (if applicable):


How reproducible:
This bug is not easily reproducible, as it is not returning any error.

If the script is executed standalone, then only it can be reproduced.

Steps to Reproduce:
1. Setup geo-replication
2. Run gverify script


Actual results:
Throws error "integer expression expected"

Expected results:
Should not throw any error. 
returns 0 for success, can be verified as echo $? after executing the script.


Additional info:
Comment 1 Vijay Bellur 2016-02-09 06:33:10 EST
REVIEW: http://review.gluster.org/13407 (geo-rep: Fix invalid disk size in gverify.sh) posted (#2) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)
Comment 2 Vijay Bellur 2016-03-01 02:57:24 EST
COMMIT: http://review.gluster.org/13407 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit a35bfdaa6279a981a84e8831d65702496f1e478e
Author: Saravanakumar Arumugam <sarumuga@redhat.com>
Date:   Tue Feb 9 16:44:03 2016 +0530

    geo-rep: Fix invalid disk size in gverify.sh
    
    Problem:
            Due to the wrong interpretation of disk size, gverify.sh script
    exits in between with error "integer expression expected".
    This error can be observed, only if gverify.sh is run standalone.
    
    Solution:
            Fix the interpretation of disk size.
    
    Also, verify that master and slave's gluster version are same.
    
    Change-Id: Id095dfffd07a93a535a380f617ad215230979870
    BUG: 1305839
    Signed-off-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    Reviewed-on: http://review.gluster.org/13407
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Niels de Vos 2016-06-16 09:57:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.