Bug 1315170 - Wrong interpretation of disk size in gverify.sh script
Wrong interpretation of disk size in gverify.sh script
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
3.7.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Saravanakumar
:
Depends On: 1305839
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 01:48 EST by Saravanakumar
Modified: 2016-03-07 01:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1305839
Environment:
Last Closed: 2016-03-07 01:56:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saravanakumar 2016-03-07 01:48:17 EST
+++ This bug was initially created as a clone of Bug #1305839 +++

Description of problem:

Run gverify script as below:
#/usr/local/libexec/glusterfs/gverify.sh  tv1 root gfvm4 tv2 22 /tmp/test.log 

Testing_Passwordless_SSH
/usr/local/libexec/glusterfs/gverify.sh: line 206: [: 1-blocks: integer expression expected

Version-Release number of selected component (if applicable):


How reproducible:
This bug is not easily reproducible, as it is not returning any error.

If the script is executed standalone, then only it can be reproduced.

Steps to Reproduce:
1. Setup geo-replication
2. Run gverify script


Actual results:
Throws error "integer expression expected"

Expected results:
Should not throw any error. 
returns 0 for success, can be verified as echo $? after executing the script.


Additional info:

--- Additional comment from Vijay Bellur on 2016-02-09 06:33:10 EST ---

REVIEW: http://review.gluster.org/13407 (geo-rep: Fix invalid disk size in gverify.sh) posted (#2) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-03-01 02:57:24 EST ---

COMMIT: http://review.gluster.org/13407 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit a35bfdaa6279a981a84e8831d65702496f1e478e
Author: Saravanakumar Arumugam <sarumuga@redhat.com>
Date:   Tue Feb 9 16:44:03 2016 +0530

    geo-rep: Fix invalid disk size in gverify.sh
    
    Problem:
            Due to the wrong interpretation of disk size, gverify.sh script
    exits in between with error "integer expression expected".
    This error can be observed, only if gverify.sh is run standalone.
    
    Solution:
            Fix the interpretation of disk size.
    
    Also, verify that master and slave's gluster version are same.
    
    Change-Id: Id095dfffd07a93a535a380f617ad215230979870
    BUG: 1305839
    Signed-off-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    Reviewed-on: http://review.gluster.org/13407
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 1 Saravanakumar 2016-03-07 01:56:22 EST
not applicable in 3.7, so closing the bug.

Note You need to log in before you can comment on or make changes to this bug.