Bug 1305871 - XJC path expansion for python sdk build
XJC path expansion for python sdk build
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-sdk-python (Show other bugs)
3.6.0
All All
unspecified Severity medium
: ovirt-3.6.3
: ---
Assigned To: Juan Hernández
Pavol Brilla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 07:49 EST by Pavol Brilla
Modified: 2016-02-17 02:33 EST (History)
8 users (show)

See Also:
Fixed In Version: rhevm-sdk-python-3.6.2.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1305482
Environment:
Last Closed: 2016-02-17 02:33:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavol Brilla 2016-02-09 07:49:00 EST
+++ This bug was initially created as a clone of Bug #1305482 +++

Description of problem:

During erratum run I received:
/usr/src/redhat/BUILD/ovirt-engine-sdk-python-3.6.2.1/generator/regenerate.xml:22: Execute failed: java.io.IOException: Cannot run program "xjc": error=2, No such file or directory


Version-Release number of selected component (if applicable):
rhevm-sdk-python-3.6.2.1-1.el6ev.noarch.rpm

How reproducible:
100%

Steps to Reproduce:
1.  run srpmtest for rhevm-sdk-python

Actual results:


Expected results:
xjc should be found

--- Additional comment from Juan Hernández on 2016-02-08 12:50:24 CET ---

This happens because we assume that the directory /usr/lib/jvm/java-1.8.0-openjdk always exists. But that isn't true, because this is created by the "alternatives" tool, and may not exist in some situations. To avoid this issue we can instead calculate JAVA_HOME like this:

JAVA_HOME=$(dirname $(rpm -ql java-1.8.0-openjdk-devel | grep '/bin$'))

--- Additional comment from Juan Hernández on 2016-02-08 12:51:56 CET ---

Pavol, do we need this fixed in order to pass TPS tests, or is there any workaround?
Comment 2 Oved Ourfali 2016-02-11 08:35:29 EST
Juan - should this be on_qa?
Comment 3 Juan Hernández 2016-02-11 08:42:12 EST
Yes, it should.
Comment 4 Gil Klein 2016-02-17 02:33:27 EST
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.