Bug 1305892 - Network setup generates uncaught exception
Network setup generates uncaught exception
Status: CLOSED DUPLICATE of bug 1297490
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.2.6
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-3.6.5
: ---
Assigned To: Yevgeny Zaspitsky
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 09:10 EST by Alexander Wels
Modified: 2016-02-18 06:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:18:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z?
ylavi: exception?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Alexander Wels 2016-02-09 09:10:40 EST
Description of problem:
When trying to run Setup Host Network an uncaught exception is generated.

Version-Release number of selected component (if applicable):
3.6.2.6

How reproducible:


Steps to Reproduce:
1. Log into the webabmin.
2. Go to Hosts->Network sub tab.
3. Click Setup Host Networks

Actual results:
An uncaught exception is thrown.

Expected results:
The Setup Host Network dialog appears and works.

Additional info:
Stack trace from the UI log:

2016-02-09 15:01:15,120 ERROR
[org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService]
(default task-21) [] Permutation name: 820D83469A671E575623913A3B35130C
2016-02-09 15:01:15,122 ERROR
[org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService]
(default task-21) [] Uncaught exception: :
com.google.gwt.core.client.JavaScriptException: (TypeError)
 __gwt$exception: <skipped>: Aab(...) is null
        at
org.ovirt.engine.ui.uicommonweb.dataprovider.AsyncDataProvider.$isNetworkExclusivenessPermissiveValidation(AsyncDataProvider.java:4259)
        at
org.ovirt.engine.ui.uicommonweb.models.hosts.network.NetworkOperationFactory.binaryOperationWithNetworkInterfaceModelAsSecondOperand(NetworkOperationFactory.java:108)
        at
org.ovirt.engine.ui.uicommonweb.models.hosts.network.NetworkOperationFactory.handleBinaryOperation(NetworkOperationFactory.java:99)
        at
org.ovirt.engine.ui.uicommonweb.models.hosts.network.NetworkOperationFactory.operationFor(NetworkOperationFactory.java:37)
        at
org.ovirt.engine.ui.uicommonweb.models.hosts.network.NetworkOperationFactory.$commandsFor(NetworkOperationFactory.java:278)
        at
org.ovirt.engine.ui.uicommonweb.models.hosts.HostSetupNetworksModel.$commandsFor(HostSetupNetworksModel.java:241)
        at
org.ovirt.engine.ui.webadmin.section.main.view.popup.host.panels.NetworkItemPanel.$menuFor(NetworkItemPanel.java:191)
        at
org.ovirt.engine.ui.webadmin.section.main.view.popup.host.panels.NetworkItemPanel.NetworkItemPanel(NetworkItemPanel.java:67)
        at
org.ovirt.engine.ui.webadmin.section.main.view.popup.host.panels.NetworkPanel.NetworkPanel(NetworkPanel.java:32)
        at
org.ovirt.engine.ui.webadmin.section.main.view.popup.host.panels.InternalNetworkPanel.InternalNetworkPanel(InternalNetworkPanel.java:17)
        at
org.ovirt.engine.ui.webadmin.section.main.view.popup.host.panels.InternalNetworkPanel.InternalNetworkPanel(InternalNetworkPanel.java:13)
        at
org.ovirt.engine.ui.webadmin.section.main.view.popup.host.HostSetupNetworksPopupView.$updateNetworks(HostSetupNetworksPopupView.java:219)
        at
org.ovirt.engine.ui.webadmin.section.main.view.popup.host.HostSetupNetworksPopupView$3.eventRaised(HostSetupNetworksPopupView.java:167)
        at org.ovirt.engine.ui.uicompat.Event.$raise(Event.java:114)
        at
org.ovirt.engine.ui.uicommonweb.models.hosts.HostSetupNetworksModel.$initNicModels(HostSetupNetworksModel.java:764)
        at
org.ovirt.engine.ui.uicommonweb.models.hosts.HostSetupNetworksModel$9.onSuccess(HostSetupNetworksModel.java:998)
        at
org.ovirt.engine.ui.frontend.Frontend$2.$onSuccess(Frontend.java:244)
[frontend.jar:]
        at
org.ovirt.engine.ui.frontend.Frontend$2.onSuccess(Frontend.java:244)
[frontend.jar:]
        at
org.ovirt.engine.ui.frontend.communication.OperationProcessor$2.$onSuccess(OperationProcessor.java:141)
[frontend.jar:]
        at
org.ovirt.engine.ui.frontend.communication.OperationProcessor$2.onSuccess(OperationProcessor.java:141)
[frontend.jar:]
        at
org.ovirt.engine.ui.frontend.communication.GWTRPCCommunicationProvider$3$1.$onSuccess(GWTRPCCommunicationProvider.java:161)
[frontend.jar:]
        at
org.ovirt.engine.ui.frontend.communication.GWTRPCCommunicationProvider$3$1.onSuccess(GWTRPCCommunicationProvider.java:161)
[frontend.jar:]
        at
com.google.gwt.rpc.client.impl.RpcCallbackAdapter.onResponseReceived(RpcCallbackAdapter.java:72)
[gwt-servlet.jar:]
        at
org.ovirt.engine.ui.common.gin.BaseSystemModule$1$1.onResponseReceived(BaseSystemModule.java:140)
        at
com.google.gwt.http.client.Request.$fireOnResponseReceived(Request.java:237)
[gwt-servlet.jar:]
        at
com.google.gwt.http.client.RequestBuilder$1.onReadyStateChange(RequestBuilder.java:409)
[gwt-servlet.jar:]
        at Unknown.Dvf/c.onreadystatechange<(Unknown Source)    at
com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335)
[gwt-servlet.jar:]
        at Unknown._t/<(Unknown Source) at Unknown.anonymous(Unknown Source)
Comment 1 Valerio 2016-02-09 11:08:26 EST
This is the network configuration.

engine server:
2 NIC. 1 dedicated to ovirtmgmt - 1 dedicated for GUI portal. (the NIC are in different subnet)

hosts:
4 NIC configured in 2 bond (2 NIC per bond). 1 bond dedicated to ovirtmgmt - 1 bond with 5 VLANs
Comment 2 Martin Mucha 2016-02-15 07:15:21 EST
I've reported this as a bug: 1303600 which was marked as a duplicate of another one and solved by yevgeny. So maybe it was just not backported to this version.
Comment 3 Yevgeny Zaspitsky 2016-02-17 05:14:53 EST
Alx/Valierio,

What is the VDSM version on the host you try to setup networks on?
Comment 4 Yevgeny Zaspitsky 2016-02-17 05:15:24 EST
Alex/Valerio,

What is the VDSM version on the host you try to setup networks on?
Comment 5 Alexander Wels 2016-02-17 08:20:16 EST
I don't know Valerio was the one reporting it on the mailing list, I simply created the bug with the relevant UI stack trace in it.
Comment 6 Valerio 2016-02-18 05:41:34 EST
Hi.

This is the VDSM on my hosts: vdsm-4.17.999-326.git86fda13.el7.centos
Comment 7 Yevgeny Zaspitsky 2016-02-18 06:18:46 EST
If that's the case, I tend to agree with Martin (Comment 2) that the bug is duplicate of Bug 1297490, which was fixed in 3.6.3.1 release.

*** This bug has been marked as a duplicate of bug 1297490 ***

Note You need to log in before you can comment on or make changes to this bug.