Bug 1305951 - Show non-empty RecipeSet comment (next to Ack/Nack radio buttons) inline instead of via pop-up
Show non-empty RecipeSet comment (next to Ack/Nack radio buttons) inline inst...
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
22
Unspecified Unspecified
low Severity low (vote)
: 23.0
: ---
Assigned To: Dan Callaghan
tools-bugs
: FutureFeature, UserExperience
Depends On: 1263917
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 11:32 EST by Arjun Shankar
Modified: 2016-07-07 19:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-07 19:10:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arjun Shankar 2016-02-09 11:32:33 EST
Problem:
When I click on a 'comment' link next to the Ack/Nack radio buttons, I get a pop-up to enter a comment. But when I fill it in, I still see the word 'comment' as a link, and I have to click through to see the actual comment in a pop-up.

RFE:
It would be nicer if: when a comment exists, it (or at least its beginning) is shown inline in the UI (as a 'link' that one can click to edit it again if needed) instead of just the word 'comment'.

My sales pitch for this RFE:
This is a rather unimportant RFE. But the reason I ask for it is that currently there is no way to even know that a comment exists in there until you actually click every 'comment' link and check what's inside the pop-up.

Notes:
I'd also like to point out that bug 1122682 is somewhat related (and may or may not conflict with this one, depending on how you plan to deal with both RFEs).
Comment 1 Roman Joost 2016-03-14 00:38:58 EDT
We are planning to address this as part of the upcoming job page improvements. There is a description of the proposed changes here:

https://beaker-project.org/dev/proposals/job-page-improvements.html
Comment 3 Dan Callaghan 2016-04-05 07:18:43 EDT
Specifically, comments are not shown directly inline (because there is not enough space for that). Each recipe set row, task row, and result row has a comment icon which also indicates the number of existing comments. Clicking that icon opens an overlay which shows all existing comments, as well as an input area for entering a new comment (if you have permission to do so).

Comments are also multi-line and interpreted as Markdown now.
Comment 5 Dan Callaghan 2016-07-07 19:10:22 EDT
Beaker 23.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.