Bug 1263917 - implement the new job page design
implement the new job page design
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: general (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 23.0
: ---
Assigned To: Dan Callaghan
tools-bugs
: FutureFeature, Patch
: 1013445 (view as bug list)
Depends On:
Blocks: 646416 853351 894137 967481 995009 1064738 1122682 1169838 1305951
  Show dependency treegraph
 
Reported: 2015-09-17 01:39 EDT by Dan Callaghan
Modified: 2018-02-05 19:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-07 19:11:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2015-09-17 01:39:13 EDT
Implement the new job page design as described here:

https://beaker-project.org/dev/proposals/job-page-improvements.html
Comment 1 Dan Callaghan 2015-09-30 19:48:34 EDT
New HTTP APIs:
http://gerrit.beaker-project.org/4406

New job page implementation:
http://gerrit.beaker-project.org/4407

There is still one big missing piece of functionality: reviews (ack/nak/comments). The team has discussed this already to some length but we are still not sure what is the best way forwards, in terms of modelling the new review system and what features it should have and how the UI should behave.

The current design proposal kind of handwaves past that, but it will need some more attention, perhaps in a separate BZ.
Comment 2 Dan Callaghan 2015-10-12 21:35:48 EDT
The HTTP APIs on the server side of things are merged now, which should make it easier to work on some other related patches. The actual job page UI itself still needs some decisions about the model and UI for reviewing (ack/nak/comments).
Comment 3 Dan Callaghan 2015-10-14 23:40:43 EDT
I noticed in my devel environment that the system page was giving a 500 if a hardware scan was in progress. It was caused by a circular reference in JSON for system when a hardware scan recipe was running (system -> recipe -> system) accidentally introduced by the job API patch.

Fix is here:
http://gerrit.beaker-project.org/4441
Comment 4 Dan Callaghan 2015-11-11 21:12:56 EST
After some discussions on the mailing list [1] we have settled on an approach for the ack/nak/commenting problem.

Recipe set comments will be separated into a fully-fledged commenting system. For this bug it will support recipe set comments only but they will be expanded to recipes/tasks in subsequent patches.

"Nak" will become "waived", "ack" will be the default. We will have a new optional mechanism for users to track whether they have reviewed a given recipe or not, inspired by Gerrit's reviewed checkboxes.

So now, with the original patch implementing the whole new UI:

http://gerrit.beaker-project.org/4407

plus some extra supporting patches:

http://gerrit.beaker-project.org/4480 extract recipe set comments into a separate table
http://gerrit.beaker-project.org/4481 support for tracking per-user recipe reviewed state
http://gerrit.beaker-project.org/4482 track per-user recipe reviewed state
http://gerrit.beaker-project.org/4486 job page: add UI for commenting on recipe sets

this is ready to go.

[1] http://thread.gmane.org/gmane.comp.systems.beaker.devel/1302
Comment 5 Mike McCune 2016-03-28 18:26:18 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Dan Callaghan 2016-04-05 03:54:11 EDT
The results-reporting-improvements-take3 branch has been merged to develop.
Comment 8 Dan Callaghan 2016-04-18 03:32:03 EDT
*** Bug 1013445 has been marked as a duplicate of this bug. ***
Comment 10 Dan Callaghan 2016-04-26 19:31:22 EDT
I'm assuming this was meant to go to VERIFIED not MODIFIED..
Comment 11 Dan Callaghan 2016-07-07 19:11:40 EDT
Beaker 23.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.