Bug 1305963 - SELinux is preventing fwupd from read, open access on the file /usr/bin/gpg2.
SELinux is preventing fwupd from read, open access on the file /usr/bin/gpg2.
Status: CLOSED DUPLICATE of bug 1310979
Product: Fedora
Classification: Fedora
Component: fwupd (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
abrt_hash:5ae85b866edb0e58d4cd42a0f34...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 11:56 EST by Stephen Gallagher
Modified: 2016-06-28 03:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-28 03:43:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2016-02-09 11:56:26 EST
Description of problem:
SELinux is preventing fwupd from read, open access on the file /usr/bin/gpg2.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that fwupd should be allowed read open access on the gpg2 file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep fwupd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:fwupd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:gpg_exec_t:s0
Target Objects                /usr/bin/gpg2 [ file ]
Source                        fwupd
Source Path                   fwupd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           gnupg2-2.1.10-3.fc24.x86_64
Policy RPM                    selinux-policy-3.13.1-169.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.5.0-0.rc2.git2.1.fc24.x86_64 #1
                              SMP Wed Feb 3 22:42:04 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2016-02-09 06:54:19 EST
Last Seen                     2016-02-09 06:54:19 EST
Local ID                      fa69f973-b6ca-4086-94f7-e4de628141a6

Raw Audit Messages
type=AVC msg=audit(1455018859.213:4183): avc:  denied  { read open } for  pid=10029 comm="fwupd" path="/usr/bin/gpg2" dev="dm-1" ino=1443339 scontext=system_u:system_r:fwupd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:gpg_exec_t:s0 tclass=file permissive=1


Hash: fwupd,fwupd_t,gpg_exec_t,file,read,open

Version-Release number of selected component:
selinux-policy-3.13.1-169.fc24.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc2.git2.1.fc24.x86_64
type:           libreport
Comment 1 Jan Kurik 2016-02-24 09:27:41 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Richard Hughes 2016-06-28 03:43:21 EDT

*** This bug has been marked as a duplicate of bug 1310979 ***

Note You need to log in before you can comment on or make changes to this bug.