Bug 1310979 - SELinux is preventing gpg2 from 'read' accesses on the file gpg.conf.
SELinux is preventing gpg2 from 'read' accesses on the file gpg.conf.
Status: CLOSED DUPLICATE of bug 1303531
Product: Fedora
Classification: Fedora
Component: fwupd (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
abrt_hash:84d09a9272b93262dca9ea207eb...
:
: 1305963 1310976 1310978 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 01:04 EST by Vít Ondruch
Modified: 2016-06-28 03:44 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-28 03:44:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2016-02-23 01:04:40 EST
Description of problem:
SELinux is preventing gpg2 from 'read' accesses on the file gpg.conf.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gpg2 should be allowed read access on the gpg.conf file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gpg2 /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:fwupd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:gpg_secret_t:s0
Target Objects                gpg.conf [ file ]
Source                        gpg2
Source Path                   gpg2
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-171.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.4.0-1.fc24.x86_64 #1 SMP Mon Jan
                              11 16:48:24 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2016-02-23 06:03:19 CET
Last Seen                     2016-02-23 06:03:19 CET
Local ID                      b1a6d1f2-19f6-4093-9e34-ca9744b9c1cb

Raw Audit Messages
type=AVC msg=audit(1456203799.114:654): avc:  denied  { read } for  pid=17596 comm="gpg2" name="gpg.conf" dev="dm-1" ino=1312681 scontext=system_u:system_r:fwupd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:gpg_secret_t:s0 tclass=file permissive=1


Hash: gpg2,fwupd_t,gpg_secret_t,file,read

Version-Release number of selected component:
selinux-policy-3.13.1-171.fc24.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.4.0-1.fc24.x86_64
type:           libreport
Comment 1 Lukas Vrabec 2016-02-25 09:26:35 EST
*** Bug 1310978 has been marked as a duplicate of this bug. ***
Comment 2 Richard Hughes 2016-04-01 11:14:49 EDT
fwupd uses gpgme (which uses gpg2) to check firmware and metadata. What's the bug?
Comment 3 Richard Hughes 2016-04-01 11:14:57 EDT
*** Bug 1310976 has been marked as a duplicate of this bug. ***
Comment 4 Richard Hughes 2016-06-28 03:43:21 EDT
*** Bug 1305963 has been marked as a duplicate of this bug. ***
Comment 5 Richard Hughes 2016-06-28 03:44:50 EDT

*** This bug has been marked as a duplicate of bug 1303531 ***

Note You need to log in before you can comment on or make changes to this bug.