Bug 1306005 - subscription-manager repos --list with bad proxy options is silently using cache
subscription-manager repos --list with bad proxy options is silently using cache
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.3
Unspecified Unspecified
low Severity medium
: rc
: 7.4
Assigned To: Kevin Howell
John Sefler
: Reopened, Triaged
: 1353821 (view as bug list)
Depends On: 1176219 1298327
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 14:34 EST by John Sefler
Modified: 2017-08-01 15:18 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1176219
Environment:
Last Closed: 2017-08-01 15:18:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github candlepin/python-rhsm/pull/183 None None None 2016-09-16 10:57 EDT
Github candlepin/subscription-manager/pull/1486 None None None 2016-09-16 10:57 EDT

  None (edit)
Comment 1 vritant 2016-07-11 15:50:38 EDT
*** Bug 1353821 has been marked as a duplicate of this bug. ***
Comment 2 RHEL Product and Program Management 2016-07-12 19:15:45 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.
Comment 4 Shwetha Kallesh 2017-04-11 02:34:17 EDT
[root@dhcp35-160 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.4-1.el7
python-rhsm: 1.19.2-1.el7

[root@dhcp35-160 ~]# subscription-manager repos --list
+----------------------------------------------------------+
    Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo ID:   rhel-7-server-openstack-11-devtools-debug-rpms
Repo Name: Red Hat OpenStack Platform 11 Developer Tools for RHEL 7 (Debug RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/7/7Server/$basearch/openstack-devtools/11/debug
Enabled:   0

Repo ID:   rhel-7-server-v2vwin-1-debug-rpms
Repo Name: Red Hat Virt V2V Tool for RHEL 7 (Debug RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/7/$releasever/$basearch/v2vwin/debug
Enabled:   0

Repo ID:   rhel-7-server-openstack-12-devtools-debug-rpms
Repo Name: Red Hat OpenStack Platform 12 Developer Tools for RHEL 7 (Debug RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/7/7Server/$basearch/openstack-devtools/12/debug
Enabled:   0

Repo ID:   rhel-7-server-aus-rhui-satellite-tools-6.3-rpms
Repo Name: Red Hat Satellite Tools 6.3 (for RHEL 7 Server - AUS) (RPMs) from RHUI
Repo URL:  https://cdn.redhat.com/content/aus/rhel/rhui/server/7/$releasever/$basearch/sat-tools/6.3/os
Enabled:   0

Repo ID:   rhel-7-server-openstack-6.0-debug-rpms
Repo Name: Red Hat OpenStack 6.0 for RHEL 7 (Debug RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/7/$releasever/$basearch/openstack/6.0/debug
Enabled:   0

Repo ID:   rhel-7-server-rhscon-2-main-source-rpms
Repo Name: Red Hat Storage Console Main for Red Hat Enterprise Linux 7 Server (Source RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/7/$releasever/$basearch/rhscon-main/2/source/SRPMS
Enabled:   0

Repo ID:   rhel-ha-for-rhel-7-server-source-rpms
Repo Name: Red Hat Enterprise Linux High Availability (for RHEL 7 Server) (Source RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/7/$releasever/$basearch/highavailability/source/SRPMS
Enabled:   0



[root@dhcp35-160 ~]# subscription-manager repos --list --proxy=auto-services.usersys.redhat.com:3128 --proxyuser=bad-username --proxypassword=bad-password
Unable to reach the server at subscription.rhsm.stage.redhat.com:443/subscription
[root@dhcp35-160 ~]#
Comment 5 errata-xmlrpc 2017-08-01 15:18:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083

Note You need to log in before you can comment on or make changes to this bug.