Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
'subscription-manager repos --list' seems to ignore the proxy option
Version-Release number of selected component (if applicable):
subscription-manager: 1.17.8-1.el7
python-rhsm: 1.17.4-1.el
How reproducible:
always
Steps to Reproduce:
1. Register to SAM and auto-attach.
2. [root@dhcp-128-18 ~]# subscription-manager repos --list --proxy=123
+----------------------------------------------------------+
Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo ID: rhel-7-server-optional-debug-rpms
Repo Name: Red Hat Enterprise Linux 7 Server - Optional (Debug RPMs)
Repo URL: https://samserv.redhat.com:8088/content/dist/rhel/server/7/$releaseve
r/$basearch/optional/debug
Enabled: 0
...
...
Repo ID: rhel-7-server-rpms
Repo Name: Red Hat Enterprise Linux 7 Server (RPMs)
Repo URL: https://samserv.redhat.com:8088/content/dist/rhel/server/7/$releaseve
r/$basearch/os
Enabled: 1
Actual results:
As step 2, repos are listed with invalid proxy option.
Expected results:
The output of step 2 should be like this:
Network error, unable to connect to server.
Please see /var/log/rhsm/rhsm.log for more information.
Additional info:
The attachment is rhsm.log
Description of problem: 'subscription-manager repos --list' seems to ignore the proxy option Version-Release number of selected component (if applicable): subscription-manager: 1.17.8-1.el7 python-rhsm: 1.17.4-1.el How reproducible: always Steps to Reproduce: 1. Register to SAM and auto-attach. 2. [root@dhcp-128-18 ~]# subscription-manager repos --list --proxy=123 +----------------------------------------------------------+ Available Repositories in /etc/yum.repos.d/redhat.repo +----------------------------------------------------------+ Repo ID: rhel-7-server-optional-debug-rpms Repo Name: Red Hat Enterprise Linux 7 Server - Optional (Debug RPMs) Repo URL: https://samserv.redhat.com:8088/content/dist/rhel/server/7/$releaseve r/$basearch/optional/debug Enabled: 0 ... ... Repo ID: rhel-7-server-rpms Repo Name: Red Hat Enterprise Linux 7 Server (RPMs) Repo URL: https://samserv.redhat.com:8088/content/dist/rhel/server/7/$releaseve r/$basearch/os Enabled: 1 Actual results: As step 2, repos are listed with invalid proxy option. Expected results: The output of step 2 should be like this: Network error, unable to connect to server. Please see /var/log/rhsm/rhsm.log for more information. Additional info: The attachment is rhsm.log