Bug 1306022 - HA | IPv6 | External LB | Deployment fails with error: Openstack Failed to parse: 2620:52:0:23a9:0:0:0:20:35357
Summary: HA | IPv6 | External LB | Deployment fails with error: Openstack Failed to pa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-cloud-config
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: y3
: 7.0 (Kilo)
Assignee: Jay Dobies
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-09 20:56 UTC by Leonid Natapov
Modified: 2016-02-18 16:53 UTC (History)
10 users (show)

Fixed In Version: os-cloud-config-0.2.8-14
Doc Type: Bug Fix
Doc Text:
Keystone client creation failed due to incorrectly parsed IPv6 addresses. This fix modifies the Keystone client creation mechanism to correctly parse IPv6 addresses. 'os-cloud-config' now creates Keystone clients successfully.
Clone Of:
Environment:
Last Closed: 2016-02-18 16:53:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 278111 None None None 2016-02-09 22:01:48 UTC
Red Hat Product Errata RHBA-2016:0264 normal SHIPPED_LIVE Red Hat Enterprise Linux OSP 7 director Bug Fix Advisory 2016-02-18 21:41:29 UTC

Description Leonid Natapov 2016-02-09 20:56:27 UTC
Description of problem:
During post config the following error shows up:

ERROR: openstack Failed to parse: 2620:52:0:23a9:0:0:0:20:35357

When using the external lb, the KeystoneAdminApiNetwork is set to internal_api in the ServiceNetMap compared to the default one that's got KeystoneAdminApiNetwork set on ctlplane. 

Looks similar to in https://bugzilla.redhat.com/show_bug.cgi?id=1299604 


Actual Results:
Deploying templates in the directory
/usr/share/openstack-tripleo-heat-templates
/home/stack/.ssh/known_hosts updated.
Original contents retained as /home/stack/.ssh/known_hosts.old
ERROR: openstack Failed to parse: 2620:52:0:23a9:0:0:0:20:35357

Expected Results:
Overcloud successfully deployed with no errors.

openstack-puppet-modules-2015.1.8-49.el7ost.noarch

Comment 2 James Slagle 2016-02-09 21:47:50 UTC
i think this error is coming from either python-rdomanager-oscplugin or os-cloud-config.

can you confirm what versions you have of those, please attach output of rpm -qa from the undercloud

Comment 3 James Slagle 2016-02-09 21:49:26 UTC
likely the error is coming from os-cloud-config when it tries to do the keystone post-config. When Keystone is on the internal_api and that network is ipv6, os-cloud-config is probably assuming ipv4 somewhere.

Comment 4 Leonid Natapov 2016-02-09 21:55:19 UTC
[stack@puma42 ~]$ rpm -qa | grep python-rdomanager-oscplugin
python-rdomanager-oscplugin-0.0.10-27.el7ost.noarch
[stack@puma42 ~]$ rpm -qa | grep os-cloud-config
os-cloud-config-0.2.8-13.el7ost.noarch

Comment 5 James Slagle 2016-02-09 22:02:49 UTC
(In reply to Leonid Natapov from comment #4)
> [stack@puma42 ~]$ rpm -qa | grep python-rdomanager-oscplugin
> python-rdomanager-oscplugin-0.0.10-27.el7ost.noarch
> [stack@puma42 ~]$ rpm -qa | grep os-cloud-config
> os-cloud-config-0.2.8-13.el7ost.noarch

thanks, i think i see what the problem is, i posted a couple of patches

Comment 7 Leonid Natapov 2016-02-11 15:20:49 UTC
os-cloud-config-0.2.8-14.el7ost.noarch

fixed.

No parsing error.

Comment 9 errata-xmlrpc 2016-02-18 16:53:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html


Note You need to log in before you can comment on or make changes to this bug.