Bug 1306100 - RHEL 7.1 docker 1.8.2 missing libdevmapper dependency
RHEL 7.1 docker 1.8.2 missing libdevmapper dependency
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.1
x86_64 Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
: Extras
: 1306101 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 20:54 EST by Øystein Bedin
Modified: 2016-06-03 16:06 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-03 16:06:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Øystein Bedin 2016-02-09 20:54:06 EST
Description of problem:
When using a RHEL7.1 system to install docker, it fails with a missing libdevmapper dependency. 

Version-Release number of selected component (if applicable):
RHEL: 7.1
Docker: 1.8.2-10
device-mapper-libs: libdevmapper.so.1.02(DM_1_02_97)

How reproducible:
Install a RHEL 7.1 system, lock it to 7.1 using "subscription-manager release" then attempt a "yum install docker".

Steps to Reproduce:
1. Install RHEL 7.1
2. Use "subscription-manager release --set=7.1" to lock it in on 7.1
3. Use "yum install docker" to see the error in dependencies

Actual results:
# yum install docker
Resolving Dependencies
--> Running transaction check
---> Package docker.x86_64 0:1.8.2-10.el7 will be installed
--> Processing Dependency: docker-selinux >= 1.8.2-10.el7 for package: docker-1.8.2-10.el7.x86_64
--> Processing Dependency: libdevmapper.so.1.02(DM_1_02_97)(64bit) for package: docker-1.8.2-10.el7.x86_64
--> Running transaction check
---> Package docker.x86_64 0:1.8.2-10.el7 will be installed
--> Processing Dependency: libdevmapper.so.1.02(DM_1_02_97)(64bit) for package: docker-1.8.2-10.el7.x86_64
---> Package docker-selinux.x86_64 0:1.8.2-10.el7 will be installed
--> Finished Dependency Resolution
Error: Package: docker-1.8.2-10.el7.x86_64 (rhel-7-server-extras-rpms)
           Requires: libdevmapper.so.1.02(DM_1_02_97)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
Docker should install A_OK on RHEL 7.1

Additional info:
Comment 2 Øystein Bedin 2016-02-09 21:07:34 EST
*** Bug 1306101 has been marked as a duplicate of this bug. ***
Comment 3 Lokesh Mandvekar 2016-02-10 09:04:36 EST
shouldn't it be --set=7.2 ?
Comment 4 Øystein Bedin 2016-02-10 10:59:16 EST
(In reply to Lokesh Mandvekar from comment #3)
> shouldn't it be --set=7.2 ?

No, should be 7.1 as outlined above. It works with RHEL 7.2, but for this scenario, we need to be able to continue using RHEL 7.1
Comment 5 Lokesh Mandvekar 2016-02-10 13:13:39 EST
Is this gonna be a blocker for 7.2.2 release? or can this wait until 7.2.3?
Comment 6 Micah Abbott 2016-02-10 13:17:46 EST
I believe Martin said this can wait until 7.2.3
Comment 7 Lokesh Mandvekar 2016-02-10 13:28:24 EST
(In reply to Micah Abbott from comment #6)
> I believe Martin said this can wait until 7.2.3

ah yes, just saw Martin's reply on IRC.

Øystein, I just wanna make sure people aren't blocked entirely until 7.2.3 (scheduled for Mar 29th). My guess is we could provide manual workarounds/support to users to fetch those dependencies and then install docker-1.8.2, correct me if I'm wrong.
Comment 8 Øystein Bedin 2016-02-10 14:13:58 EST
(In reply to Lokesh Mandvekar from comment #7)
> (In reply to Micah Abbott from comment #6)
> > I believe Martin said this can wait until 7.2.3
> 
> ah yes, just saw Martin's reply on IRC.
> 
> Øystein, I just wanna make sure people aren't blocked entirely until 7.2.3
> (scheduled for Mar 29th). My guess is we could provide manual
> workarounds/support to users to fetch those dependencies and then install
> docker-1.8.2, correct me if I'm wrong.

I'm not sure about the relationship between 7.2.3 and 7.1 for docker dependencies, but this is an issue with RHEL 7.1 that needs to be addressed. In other words, seems that docker was update but not the dependencies that go with RHEL 7.1. As long as the correct dependencies are made available in some way for 7.1, that would be all that's needed from what I can tell.
Comment 10 Lokesh Mandvekar 2016-02-10 16:48:17 EST
(In reply to Øystein Bedin from comment #8)
> 
> I'm not sure about the relationship between 7.2.3 and 7.1 for docker
> dependencies, but this is an issue with RHEL 7.1 that needs to be addressed.
> In other words, seems that docker was update but not the dependencies that
> go with RHEL 7.1. As long as the correct dependencies are made available in
> some way for 7.1, that would be all that's needed from what I can tell.

Looks like device-mapper-libs for 7.1 isn't going to work for the existing docker and this looks like something to be handled on the device-mapper side itself. Do you know if it's possible to upgrade device-mapper itself on 7.1?

A workaround could be enabling some repos to install a device-mapper update and disabling them after the update is done. Would that be ok?
Comment 11 Øystein Bedin 2016-02-10 17:00:35 EST
(In reply to Lokesh Mandvekar from comment #10)
> (In reply to Øystein Bedin from comment #8)
> > 
> > I'm not sure about the relationship between 7.2.3 and 7.1 for docker
> > dependencies, but this is an issue with RHEL 7.1 that needs to be addressed.
> > In other words, seems that docker was update but not the dependencies that
> > go with RHEL 7.1. As long as the correct dependencies are made available in
> > some way for 7.1, that would be all that's needed from what I can tell.
> 
> Looks like device-mapper-libs for 7.1 isn't going to work for the existing
> docker and this looks like something to be handled on the device-mapper side
> itself. Do you know if it's possible to upgrade device-mapper itself on 7.1?
> 
> A workaround could be enabling some repos to install a device-mapper update
> and disabling them after the update is done. Would that be ok?

I have looked for an update to device-mapper-libs, but haven't found a repo that has a newer version available for RHEL 7.1. If you can point me to one, that would be great. 

Temporarily enabling a repo for this purpose would be fine as a workaround to get us going, but probably not as a permanent fix for 7.1.
Comment 12 Lokesh Mandvekar 2016-02-11 15:18:23 EST
(In reply to Øystein Bedin from comment #11)
> I have looked for an update to device-mapper-libs, but haven't found a repo
> that has a newer version available for RHEL 7.1. If you can point me to one,
> that would be great. 
> 
> Temporarily enabling a repo for this purpose would be fine as a workaround
> to get us going, but probably not as a permanent fix for 7.1.

But if we do this, would that resulting distro still be 7.1? Guess not. Is an upgrade to 7.1.x or 7.2 an absolute no-no for the user? I gotta check if this is something that can be fixed in the docker side or if it's an absolute requirement to update device-mapper.
Comment 17 Subhendu Ghosh 2016-03-31 17:07:54 EDT
Docker currently has, and  may continue to have dependencies on underlying features that were released after RHEL 7.1. In order to update to a newer version of Docker, all the underlying dependencies must be satisfied. 

In this particular instance there is a requirement to upgrade the device-mapper-libs to a minimum version required by Docker for feature and bug fix support. device-mapper-libs in turn may have other dependencies.

Hence the statement is Docker update must be rpm dependency complete at the very least and certain features of Docker might require installation or upgrade of other elements as well (ex. Docker+overlayfs support requires the RHEL 7.2 kernel as a minimum kernel level).
Comment 18 Lokesh Mandvekar 2016-05-23 14:56:06 EDT
Can we close this one?

Note You need to log in before you can comment on or make changes to this bug.