Bug 1306182 - A single failure makes the whole monitoring line red
A single failure makes the whole monitoring line red
Status: CLOSED CURRENTRELEASE
Product: Copr
Classification: Community
Component: frontend (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jakub Kadlčík
:
: 1309603 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 04:09 EST by Fabio Alessandro Locati
Modified: 2016-03-29 08:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-29 08:20:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Alessandro Locati 2016-02-10 04:09:33 EST
If a build fails on a single platform is marked as failed for every platform

Also, I've noticed that today (compared to a week ago) in the "Monitor" tab - during building - all platforms are marked as building even if some of them have already completed.
Comment 1 Elliott Sales de Andrade 2016-02-18 22:22:21 EST
This is rather annoying since all of my builds are now "pending" since the wait for ppc is usually quite long. It makes it difficult to find builds that actually failed but I never got around to re-submitting.
Comment 2 clime 2016-03-01 03:44:31 EST
*** Bug 1309603 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Kadlčík 2016-03-08 06:42:56 EST
Hello guys, thank you for the feedback.

> If a build fails on a single platform is marked as failed for every platform

When we are talking about `build state` or `package state` that means only one value representing the whole build, expected behavior is to show the most pessimistic option. (i.e. if one chroot fails and all other chroots succeeds, the whole build is marked as failed). But of course when you see details of the build, every chroot should show it's proper state. If it doesn't work this way, please refer me on the page/build which is bugged.


> Also, I've noticed that today (compared to a week ago) in the "Monitor" tab -
> during building - all platforms are marked as building even if some of them 
> have already completed.

I confirm a bug.
Modified in: 9e53dd6
Comment 4 Jens Petersen 2016-03-08 22:29:10 EST
The report is about the Monitor page.
Comment 5 Jakub Kadlčík 2016-03-15 04:47:53 EDT
Code with this fix is currently deployed on testing server.
You can test it before it will be deployed to production.
Please see: http://copr-fe-dev.cloud.fedoraproject.org
Comment 6 Fabio Alessandro Locati 2016-03-16 05:42:19 EDT
(In reply to Jakub Kadlčík from comment #5)
> Code with this fix is currently deployed on testing server.
> You can test it before it will be deployed to production.
> Please see: http://copr-fe-dev.cloud.fedoraproject.org

On the dev version is working as expected :)
Comment 7 Jakub Kadlčík 2016-03-29 08:20:45 EDT
Copr production machines were upgraded to version containing a fix to this issue.
If you are not satisfied with provided solution, please feel free to reopen this.

Note You need to log in before you can comment on or make changes to this bug.