Bug 1306324 - [scale] - GetStorageConnectionsByStorageTypeAndStatus generate slow query
[scale] - GetStorageConnectionsByStorageTypeAndStatus generate slow query
Status: CLOSED DUPLICATE of bug 1306325
Product: ovirt-engine
Classification: oVirt
Component: Database.Core (Show other bugs)
3.6.2
x86_64 Linux
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Eli Mesika
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 10:07 EST by Eldad Marciano
Modified: 2016-02-10 10:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 10:21:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Eldad Marciano 2016-02-10 10:07:13 EST
Description of problem:
SP GetStorageConnectionsByStorageTypeAndStatus response time grow when running 
many SD's

--10 rows \ SD's exe time = ~3.2sec

--1 row \ SD exe time = ~1.2sec

Version-Release number of selected component (if applicable):
rhevm 3.6.2

How reproducible:
100%

Steps to Reproduce:
1. 10K vms 12 SD's

Actual results:
execution time ~3 sec and above.

Expected results:
less than 1 sec.

Additional info:
Comment 1 Eldad Marciano 2016-02-10 10:21:20 EST

*** This bug has been marked as a duplicate of bug 1306325 ***

Note You need to log in before you can comment on or make changes to this bug.