This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1306325 - [scale] - GetStorageConnectionsByStorageTypeAndStatus generate slow query for multiple SD's
[scale] - GetStorageConnectionsByStorageTypeAndStatus generate slow query for...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Database.Core (Show other bugs)
3.6.2
x86_64 Linux
unspecified Severity medium (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Allon Mureinik
Eldad Marciano
:
: 1306324 (view as bug list)
Depends On:
Blocks: 1337257
  Show dependency treegraph
 
Reported: 2016-02-10 10:07 EST by Eldad Marciano
Modified: 2016-08-11 11:05 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1337257 (view as bug list)
Environment:
Last Closed: 2016-08-11 11:05:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑4.0.0?
ylavi: planning_ack+
amureini: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53687 None None None 2016-06-01 08:54 EDT

  None (edit)
Description Eldad Marciano 2016-02-10 10:07:44 EST
Description of problem:
SP GetStorageConnectionsByStorageTypeAndStatus response time grow when running 
many SD's

--10 rows \ SD's exe time = ~3.2sec

--1 row \ SD exe time = ~1.2sec

Version-Release number of selected component (if applicable):
rhevm 3.6.2

How reproducible:
100%

Steps to Reproduce:
1. 10K vms 12 SD's

Actual results:
execution time ~3 sec and above.

Expected results:
less than 1 sec.

Additional info:
Comment 1 Eldad Marciano 2016-02-10 10:20:55 EST
performance improved when using this patch:
https://gerrit.ovirt.org/#/c/52912/

depends on:
https://bugzilla.redhat.com/show_bug.cgi?id=1302794
Comment 2 Eldad Marciano 2016-02-10 10:21:20 EST
*** Bug 1306324 has been marked as a duplicate of this bug. ***
Comment 3 Eldad Marciano 2016-02-10 10:22:40 EST
--10 rows \ SD's exe time = 485ms
--1 row \ SD exe time = 495ms
Comment 4 Eli Mesika 2016-03-29 09:43:17 EDT
So, IIUC from comment 1 https://gerrit.ovirt.org/#/c/52912/ solved the issue 
Please approve
Comment 5 Sandro Bonazzola 2016-05-02 05:51:27 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 6 Eldad Marciano 2016-05-03 07:31:14 EDT
approve.
any chance to back-port?
Comment 7 Martin Perina 2016-05-03 07:38:09 EDT
Allon, do you agree backporting https://gerrit.ovirt.org/52912 into 3.6?
Comment 8 Allon Mureinik 2016-05-05 08:31:10 EDT
(In reply to Martin Perina from comment #7)
> Allon, do you agree backporting https://gerrit.ovirt.org/52912 into 3.6?

The backport is a bit tricky, but it's easy to verify, and once verified it shouldn't be too risky. 
Taking the BZ, and will handle the BZ for 3.6.7, as to not add additional risk to 3.6.6
Comment 9 Allon Mureinik 2016-05-18 11:53:16 EDT
Messed up the flags a bit here, sorry. 
This bug is ON_QA for 4.0 alpha release.
I'll clone it to a new one for 3.6.7 since the schemas have diverged quite a bit, and I'd like it to be verified on both branches.
Comment 10 Gil Klein 2016-08-11 11:05:17 EDT
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.