Bug 1306362 - CloudForms inventory fails when an openstack cinder volume contains no 'device' directive in the attachments property
CloudForms inventory fails when an openstack cinder volume contains no 'devic...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.3
Assigned To: Ladislav Smola
Pavol Kotvan
openstack
: ZStream
Depends On: 1304740 1306363
Blocks: 1306361
  Show dependency treegraph
 
Reported: 2016-02-10 11:38 EST by Chris Pelland
Modified: 2016-04-13 14:43 EDT (History)
13 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Previously, CloudForms inventory failed when an OpenStack cinder volume contained no 'device' directive in the attachments property. This was caused because the mountpoit of a volume went missing after some operations. This fix ignores the missing volume mountpoint, and logs a warning. As a result, the inventory now succeeds.
Story Points: ---
Clone Of: 1304740
Environment:
Last Closed: 2016-04-13 14:43:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2016-03-11 09:59:43 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=81711115ce3f9a2e36ddb8bd9782954498bc9113

commit 81711115ce3f9a2e36ddb8bd9782954498bc9113
Merge: 92f363c 37a97bb
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Fri Mar 11 09:34:01 2016 -0500
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Fri Mar 11 09:34:01 2016 -0500

    Merge branch 'bz1306362' into '5.5.z'
    
    OpenStack ignore missing volume mountpoint
    
    Seems like after some operations, the mountpoit of volume can
    get missing. Let's ignore that fact and log warn.
    
    Clean cherry-pick of:
    https://github.com/ManageIQ/manageiq/pull/6592
    
    Fixes 5.5.z BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1306362
    
    See merge request !777

 .../manageiq/providers/openstack/cloud_manager/refresh_parser.rb    | 6 ++++++
 1 file changed, 6 insertions(+)
Comment 10 errata-xmlrpc 2016-04-13 14:43:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.