Bug 1306433 - /etc/cron.hourly/miq_top_hourly calls /bin/miqtop which does not exist
/etc/cron.hourly/miq_top_hourly calls /bin/miqtop which does not exist
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.4.5
Assigned To: Nick Carboni
Ramesh A
appliance
: ZStream
Depends On: 1306385
Blocks: 1306430
  Show dependency treegraph
 
Reported: 2016-02-10 15:58 EST by Chris Pelland
Modified: 2017-08-29 22:01 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.4.5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1306385
Environment:
Last Closed: 2016-03-29 10:18:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2016-02-11 16:07:40 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=8971332030cb9d1b82d91790f0f4c0a7f73c7dd9

commit 8971332030cb9d1b82d91790f0f4c0a7f73c7dd9
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Wed Feb 10 16:29:24 2016 -0500
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Wed Feb 10 16:29:24 2016 -0500

    Write the correct file name to miq_top_hourly
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1306433

 system/LINK/bin/miqtop.sh | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 3 CFME Bot 2016-02-11 16:07:44 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=6d59dd92ed4d9ffcf342d98c8186a2992093632f

commit 6d59dd92ed4d9ffcf342d98c8186a2992093632f
Merge: b7fbbc0 8971332
Author:     Joe Rafaniello <jrafanie@redhat.com>
AuthorDate: Thu Feb 11 16:07:07 2016 -0500
Commit:     Joe Rafaniello <jrafanie@redhat.com>
CommitDate: Thu Feb 11 16:07:07 2016 -0500

    Merge branch 'restart_miqtop_miqvmstat_with_cron' into '5.4.z'
    
    Write the correct file name to miq_top_hourly
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1306433
    
    This change has no real upstream counterpart as the miqtop and miqvmstat services were refactored into systemd units as of version 5.5
    
    See merge request !780

 system/LINK/bin/miqtop.sh | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 5 Ramesh A 2016-03-22 07:55:59 EDT
Good to go.  Verified and working fine in 5.4.5.2.20160315175001_800759c

Typo error seems to be fixed in the above mentioned build.

[root@server ~]# cat /etc/cron.hourly/miq_top_hourly
#!/bin/sh
#
echo "miqtop: timesync: date time is-> $(date) $(date +%z)" >> /var/www/miq/vmdb/log/top_output.log
echo "miqtop: timesync: date time is-> $(date) $(date +%z)" >> /var/www/miq/vmdb/log/vmstat_output.log
/bin/miqtop.sh start > /dev/null 2>&1
[root@server ~]#
Comment 7 errata-xmlrpc 2016-03-29 10:18:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0171.html

Note You need to log in before you can comment on or make changes to this bug.