Bug 1306540 - Evolution will not show Exchange EWS account if there was an account previously configured for that address
Evolution will not show Exchange EWS account if there was an account previous...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 04:03 EST by Tim Wegener
Modified: 2016-12-20 21:31 EST (History)
8 users (show)

See Also:
Fixed In Version: evolution-data-server-3.22.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 879773
Environment:
Last Closed: 2016-02-15 05:30:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Wegener 2016-02-11 04:03:55 EST
+++ This bug was initially created as a clone of Bug #879773 +++

Description of problem:
Exchange online account not appear in evolution

Please see demonstration video: https://docs.google.com/open?id=0B0nwzlfiB4aQNVRtQ2syN3VCNGM


--- Additional comment from Mikhail on 2012-11-28 02:55:46 EST ---

(In reply to comment #5)
> Yes, evolution-ews is part of Fedora since Fedora 16, regardless Fedora's
> alpha/beta/final stage, though only recently had been added EWS support into
> Gnome Online Accounts.
> 

I mean that evolution-ews by default installed in F18 beta, but not installed in F18 alpha.

> (In reply to comment #4)
> Does it mean that it started to work? If so, then I'm not sure what to do
> with this bug report then. I believe there is some flaw in the code, your
> video showed it, but I cannot reproduce it, and the part I thought is
> involved, which I described in above comments, is probably related, though I
> currently do not know how to address it properly, because at least
> autodiscover on the evolution-source-registry part should also finish before
> the account is auto-added (this autodiscover can cause the delay in account
> addition).

With fresh install F18 beta (I am testing anaconda), I am used /home partition from my previous installation (F18 alpha) and after reboot and launching evolution I see two evolution-ews accounts.
First from my F17 which been installed before F18 alpha, second which I added when testing online accounts in F18 alpha.

--- Additional comment from Milan Crha on 2012-11-28 03:19:05 EST ---

(In reply to comment #6)
> I mean that evolution-ews by default installed in F18 beta, but not
> installed in F18 alpha.

Aah, I see, that's true, and I forgot of it completely. That's another reason which can cause no email account in evolution with EWS configured through Online Accounts. The missing evolution-ews makes no account in evolution, which makes sense.

> With fresh install F18 beta (I am testing anaconda), I am used /home
> partition from my previous installation (F18 alpha) and after reboot and
> launching evolution I see two evolution-ews accounts.
> First from my F17 which been installed before F18 alpha, second which I
> added when testing online accounts in F18 alpha.

I see, it's pretty expected, the account information is stored in ~/.config/evolution/sources, and the old EWS account was found too. If you want to make it clean for evolution, then delete
   ~/.local/share/evolution
   ~/.config/evolution
   ~/.cache/evolution
before any evolution process will be started, then you'll start from scratch.

--- Additional comment from Tim Wegener on 2016-02-11 02:36:45 EST ---

Still happens in Fedora 22.

evolution-3.16.5-3.fc22.x86_64
evolution-ews-3.16.5-1.fc22.x86_64
evolution-mapi-3.16.4-1.fc22.x86_64

I originally created a mapi account for the given email address.
Then I tried to add an ews account for that same address and while it would accept my entries in the wizard, it would not display the new account.
Similarly after deleting the mapi account, and restarting evolution.

The workaround mentioned above plus 'pkill evolution' allowed it to work.
Comment 1 Milan Crha 2016-02-11 06:19:09 EST
Thanks for a bug report, or a clone, whatever. There is no problem to create both evolution-ews and evolution-mapi accounts for the same server and the same user, the only limitation is that the server supports both protocols.

More important question is: when did you install the evolution-ews?

By the way, the version series 3.16.x is ancient, the current stable is 3.18.4, which will be superseded with 3.18.5 release the next week, and even more importantly with 3.20.0 release in the next few weeks.

If this is about the issue of installing evolution-ews, but not restarting background processes, thus the newly added modules could be loaded, then it is addresses in the 3.20.0.
Comment 2 Tim Wegener 2016-02-12 19:34:14 EST
(In reply to Milan Crha from comment #1)
...
> More important question is: when did you install the evolution-ews?


IIRC, the sequence was roughly:

1. Install evolution-mapi.
2. Set up email account using MAPI. (This worked.)
3. Install evolution-ews.
4. Set up email account using EWS. (The wizard accepted everything, but the account did not show up after finishing it.)
5. Restarting evolution and trying again did not help.
6. Removing the MAPI account, clearing out the config and killing all evolution-related processes, starting evolution and adding the account using EWS worked fine.
Comment 3 Milan Crha 2016-02-15 05:30:02 EST
Thanks for the information. The restart of the background processes made it work. As I noted above, this will be fixed with 3.20.0, thus I'm closing this.
Comment 4 Matt Moldvan 2016-12-20 09:53:23 EST
Seems this has reappeared in 3.22.3-1 in Fedora 25?

Steps to reproduce:

1. yum install evolution
2. didn't see the Exchange Web Services options, closed Evolution
3. yum install evolution-ews
4. Exchange Web Services option is now available
5. Try to add the account 3 times, no luck saving it any of those times
6. pkill evolution (which I guess killed the calendar and address book processes), launch Evolution again, my 3 previous attempts at adding the EWS account showed up (with unrelated connection errors) 

Maybe something in the evolution-ews package could be added to kill/restart/notify these processes in some way to avoid extra work for a new user?

[mmoldva@office ~]$ ps -fe | grep evolu
mmoldva   2139  1826  0 Dec19 ?        00:00:00 /usr/libexec/evolution-source-registry
mmoldva   2393  1826  0 Dec19 ?        00:00:00 /usr/libexec/evolution-calendar-factory
mmoldva   2441  2393  0 Dec19 ?        00:00:00 /usr/libexec/evolution-calendar-factory-subprocess --factory contacts --bus-name org.gnome.evolution.dataserver.Subprocess.Backend.Calendarx2393x2 --own-path /org/gnome/evolution/dataserver/Subprocess/Backend/Calendar/2393/2
mmoldva   2489  2393  0 Dec19 ?        00:00:00 /usr/libexec/evolution-calendar-factory-subprocess --factory local --bus-name org.gnome.evolution.dataserver.Subprocess.Backend.Calendarx2393x3 --own-path /org/gnome/evolution/dataserver/Subprocess/Backend/Calendar/2393/3
mmoldva   2490  1826  0 Dec19 ?        00:00:00 /usr/libexec/evolution-addressbook-factory
mmoldva   2522  2490  0 Dec19 ?        00:00:00 /usr/libexec/evolution-addressbook-factory-subprocess --factory local --bus-name org.gnome.evolution.dataserver.Subprocess.Backend.AddressBookx2490x2 --own-path /org/gnome/evolution/dataserver/Subprocess/Backend/AddressBook/2490/2
mmoldva  31230  1826  0 09:41 pts/0    00:00:00 /usr/libexec/evolution/evolution-alarm-notify
mmoldva  32232 30903  0 09:50 pts/0    00:00:00 grep --color=auto evolu
[mmoldva@office ~]$ sudo pkill evolution
[mmoldva@office ~]$ ps -fe | grep evolu
mmoldva  32263 30903  0 09:50 pts/0    00:00:00 grep --color=auto evolu
Comment 5 Milan Crha 2016-12-20 10:08:14 EST
That's inside the evolution-source-registry, which should (in 3.22.x for sure) load the added modules and start working. The calendar and addressbook factories are different, I think, but maybe not. It's a long time since I made those changes. I'll retest here and will let you know.
Comment 6 Milan Crha 2016-12-20 13:06:28 EST
Okay, you are right. The code were checking only for newly created files and moved-in files, but not for renamed files, where the package manager copies the file under a different name first, then renames it to the right name, which the code ignored. I changed it for the next releases:

Created commit 664cfac in eds master (3.23.4+) [1]
Created commit 71d6c78 in eds gnome-3-22 (3.22.4+) [2]

[1] https://git.gnome.org/browse/evolution-data-server/commit/?id=664cfac
[2] https://git.gnome.org/browse/evolution-data-server/commit/?id=71d6c78
Comment 7 Matt Moldvan 2016-12-20 21:31:47 EST
Awesome, thanks for the quick turn around!

Note You need to log in before you can comment on or make changes to this bug.