Bug 130657 - "nfs warning: mount version older than kernel"
"nfs warning: mount version older than kernel"
Status: CLOSED DUPLICATE of bug 133708
Product: Fedora
Classification: Fedora
Component: am-utils (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Depends On:
  Show dependency treegraph
Reported: 2004-08-23 10:29 EDT by Patrick J. LoPresti
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-11 04:09:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Patrick J. LoPresti 2004-08-23 10:29:24 EDT
Description of problem:

Every time amd mounts a remote NFS file system, the kernel logs the
message "nfs warning: mount version older than kernel".  I realize
this is only a warning, but it is filling our logs because we use amd
on our network continuously.

Version-Release number of selected component (if applicable):

I am using kernel-2.6.7-1.494.2.2 and am-utils-6.0.9-6.1

How reproducible:


Steps to Reproduce:
1. Configure an amd mount point to mount an NFS filesystem
2. Access the mount point
3. Observe the warning on the console and in the logs
Actual results:

Warning message in logs

Expected results:

Quiet behavior for successful mount

Additional info:

I believe this is a bug in amd; it is using an old style mount() call
or data structure.  I suspect a minor patch to amd, or possibly just a
recompile against newer headers, would fix it.  But I have not
investigated this carefully.
Comment 1 Roberto Alcântara Filho 2004-08-24 11:24:20 EDT
I have this problem with Linux version,Fedora Core 1, and 
solve that updating modutils and nfs-utils to modutils-2.4.26-16 and  
Comment 2 Patrick J. LoPresti 2004-08-24 11:29:16 EDT
I am already running modutils-2.4.26-16 and nfs-utils-1.0.6-22, so
that is not the problem.

This is a problem with am-utils and the 2.6 kernel in FC2.
Comment 3 Peter Vrabec 2005-04-11 04:09:43 EDT

*** This bug has been marked as a duplicate of 133708 ***

Note You need to log in before you can comment on or make changes to this bug.