Bug 1306579 - Could not connect to host with certificate vefirication via freerdp on ppc64 and s390x
Could not connect to host with certificate vefirication via freerdp on ppc64 ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: freerdp (Show other bugs)
6.7
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Ondrej Holy
Desktop QE
:
: 1309717 (view as bug list)
Depends On: 1204742
Blocks: 1215093
  Show dependency treegraph
 
Reported: 2016-02-11 05:58 EST by Tomas Hudziec
Modified: 2016-07-15 05:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-15 05:20:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Hudziec 2016-02-11 05:58:12 EST
Description of problem:
Could not connect to host with certificate vefirication via freerdp on ppc64 and s390x.
Even with correct password, error message appears and program is shutted down.

Version-Release number of selected component (if applicable):
freerdp-1.0.2-4.el6.(ppc64|s390x)

How reproducible:
always

Steps to Reproduce:
1. xfreerdp $WindowsIP

Actual results:
Even with correct password, error message below appears and program is shutted down.
"SSL_read: Failure in SSL library (protocol error?)
Authentication failure, check credentials.
If credentials are valid, the NTLMSSP implementation may be to blame."

Expected results:
xfreerdp connects to remote desktop

Additional info:
This is arch specific bug, appears on ppc64 and s390x; x86_64 and i386 are fine.
Comment 2 Ondrej Holy 2016-02-11 06:42:03 EST
There is already bug report for RHEL 7.
Comment 3 Ondrej Holy 2016-02-11 08:21:24 EST
You may use non-nla security as a workaround, see Bug 1204742.
Comment 4 Ondrej Holy 2016-02-12 10:08:46 EST
I hoped it is fixed upstream, but it seems it is even worse. I tried several newer versions and the result is same, or it crashes with segfaults instead.

Several upstream reports exists in regards to endianness problems. Probably the most relevant one is following:
https://github.com/FreeRDP/FreeRDP/issues/2520
Comment 5 Marek Kašík 2016-02-19 11:35:15 EST
*** Bug 1309717 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.