Bug 1309717 - Vinagre can't connect to RDP due SSL error
Vinagre can't connect to RDP due SSL error
Status: CLOSED DUPLICATE of bug 1306579
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vinagre (Show other bugs)
6.8
ppc64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Marek Kašík
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 09:44 EST by Vaclav Ehrlich
Modified: 2016-02-19 11:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-19 11:35:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vaclav Ehrlich 2016-02-18 09:44:56 EST
Description of problem:
While try to login via RDP, connection is refused as Authentication failure. But with same credentials is possible to connect from x86_64 version of vinagre.

Version-Release number of selected component (if applicable):
vinagre-2.28.1-9.el6.ppc64

How reproducible:
Always

Steps to Reproduce:
1.Clear all records for host you want to connect to from /home/test/.freerdp/
2.Open vinagre and try to connect to host (fill up username and domain and RDP protocol)
3.Provide valid password
4.Confirm you want to use certificate from host

Actual results:
Dialog window for reentering whole authentication credentials appears

Expected results:
User is connected to host

Additional info:
There was no error with 
vinagre-2.28.1-9.el6.x86_64
or 
vinagre-3.16.1-1.fc22.x86_64

Console output:
SSL_read: Failure in SSL library (protocol error?)
Authentication failure, check credentials.
If credentials are valid, the NTLMSSP implementation may be to blame.
Comment 2 Marek Kašík 2016-02-19 11:35:15 EST
This is actually a duplicate of the FreeRDP bug #1306579.

*** This bug has been marked as a duplicate of bug 1306579 ***

Note You need to log in before you can comment on or make changes to this bug.