Bug 1306637 - ovirt-image-uploader should warn it's deprecated and will be removed in next version
ovirt-image-uploader should warn it's deprecated and will be removed in next ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-image-uploader
Classification: oVirt
Component: General (Show other bugs)
4.0.0
Unspecified Unspecified
medium Severity low (vote)
: ovirt-4.0.0-rc
: 4.0.0
Assigned To: Rafael Martins
Gonza
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 09:00 EST by Sandro Bonazzola
Modified: 2017-05-11 05:27 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Deprecated Functionality
Doc Text:
The ovirt-image-uploader tool has been deprecated in Red Hat Virtualization 4.0, and will be removed in Red Hat Virtualization 4.1.
Story Points: ---
Clone Of: 1210799
Environment:
Last Closed: 2016-07-05 03:51:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 57872 master MERGED ovirt-image-uploader: show deprecation warning 2016-05-30 17:10 EDT

  None (edit)
Description Sandro Bonazzola 2016-02-11 09:00:41 EST
+++ This bug was initially created as a clone of Bug #1210799 +++

--- Additional comment from Sandro Bonazzola on 2016-02-04 10:42:31 EST ---

Yaniv, should we provide the tool and mark as deprecated in 4.0?
Or deprecate in 3.6 and drop in 4.0?

--- Additional comment from Yaniv Dary on 2016-02-09 13:22:36 EST ---

(In reply to Sandro Bonazzola from comment #3)
> Yaniv, should we provide the tool and mark as deprecated in 4.0?
> Or deprecate in 3.6 and drop in 4.0?

I think the first option. Deprecated in 4.0, I believe 4.1 will allow to upload via GUI\REST.
Comment 1 Sandro Bonazzola 2016-05-02 05:59:05 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 2 Sandro Bonazzola 2016-05-20 07:10:54 EDT
Will be deprecated by Bug #1122970 - [RFE] ISO image uploader in the GUI
Comment 3 Yaniv Lavi 2016-05-23 09:15:53 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 4 Yaniv Lavi 2016-05-23 09:19:43 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 5 Gonza 2016-06-24 07:00:58 EDT
Verified with:
ovirt-image-uploader-4.0.0-1.fc23.noarch

# engine-image-uploader -e export_domain -N TinyCore upload TinyCore-current.iso 
WARNING: ovirt-image-uploader is deprecated in 4.0 and will be removed in 4.1
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to abort):
Comment 6 Sandro Bonazzola 2016-07-05 03:51:32 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.