Bug 1122970 - [RFE] Allow uploading ISO images to data domains and using them in VMs
Summary: [RFE] Allow uploading ISO images to data domains and using them in VMs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: unspecified
Hardware: All
OS: All
medium
medium
Target Milestone: ovirt-4.2.1
: ---
Assignee: Tal Nisan
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
: 630655 706873 RHEV_ISO_Uploader_UI 1093548 (view as bug list)
Depends On: RHEV_ISO_Uploader_UI, RHEV_ISO_Uploader_UI 1314387 1317253 1532537 1536826
Blocks: 1417161 1058798 1148699 1511420 1530730 1548856
TreeView+ depends on / blocked
 
Reported: 2014-07-24 13:39 UTC by Daniel Erez
Modified: 2019-05-17 10:35 UTC (History)
36 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
In the current release, an ISO image file can be uploaded, via the Manager or the REST API, to a data storage domain and attached to a virtual machine as a CDROM device.
Clone Of: RHEV_ISO_Uploader_UI, RHEV_ISO_Uploader_UI
: 1530730 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:36:09 UTC
oVirt Team: Storage
sherold: Triaged+
ratamir: testing_plan_complete+


Attachments (Terms of Use)
mockup: Images sub-tab: action buttons (47.12 KB, image/png)
2014-08-04 16:44 UTC, Einav Cohen
no flags Details
mockup: "Upload Image" dialog (39.77 KB, image/png)
2014-08-04 16:44 UTC, Einav Cohen
no flags Details
mock-up: Import Disk (108.52 KB, image/png)
2015-03-23 20:15 UTC, Einav Cohen
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 None None None 2018-05-15 17:38:11 UTC
oVirt gerrit 83136 master MERGED core: Allow uploading of ISO images through webadmin 2017-10-29 15:45:18 UTC
oVirt gerrit 84434 master MERGED core: Allow attach as CD of ISO images from data domain in webadmin 2017-12-26 12:16:52 UTC
oVirt gerrit 85018 master MERGED storage: Allow attaching a cdrom device from block domain 2017-12-26 11:30:27 UTC
oVirt gerrit 85019 master MERGED core: Allow attaching ISO file on data domains to VM as a cdrom 2017-12-26 12:16:55 UTC
Red Hat Bugzilla 1210799 None CLOSED Build ovirt-image-uploader for RHEL 7 RHEV 4.0 2019-09-18 07:28:43 UTC

Internal Links: 1210799

Description Daniel Erez 2014-07-24 13:39:35 UTC
+++ This bug was initially created as a clone of Bug #1091377 +++

Description of problem:
It would be helpful to be able to upload iso images through the gui.
Being able to add them through the hosted engine and through nfs is fine in many cases of course, but a more integrated solution into the webgui would be great.

Letting users choose their own iso seems a better solution in many cases, especially if it can go under their own resource pool.

First time poster, so please tell me if I'm doing anything incorrectly.

With my best regards
Klas

--- Additional comment from Sean Cohen on 2014-07-24 09:37:32 EDT ---

Comment 1 Sean Cohen 2014-07-24 13:41:53 UTC
*** Bug 1093548 has been marked as a duplicate of this bug. ***

Comment 2 Einav Cohen 2014-08-04 16:44:20 UTC
Created attachment 923963 [details]
mockup: Images sub-tab: action buttons

Comment 3 Einav Cohen 2014-08-04 16:44:50 UTC
Created attachment 923964 [details]
mockup: "Upload Image" dialog

Comment 4 Einav Cohen 2014-08-04 16:48:35 UTC
graphic design is pretty straight forward IMO:

- add "Upload", "Edit" (? maybe not needed) and "Remove" buttons to the "Images" sub-tab (displayed when an ISO domain is selected in the Storage main tab).
[see attachment 923963 [details]]

- Once "Upload" is clicked, the "Upload Image" dialog is opened. 
[see attachment 923964 [details]]

-  "Edit" opens an "Edit Image", which should be identical to the "Upload Image" dialog, with the information filled and potentially some of the fields disabled (again, probably doesn't make sense, hence not needed). 

- "Remove" should open a standard "are you sure" confirmation dialog.

Comment 5 Sandro Bonazzola 2014-08-13 08:31:32 UTC
Moving to storage: it's a change needed in the engine webadmin for importing an image in an iso domain. Doesn't look like an integration task.

Comment 6 Allon Mureinik 2015-01-24 12:51:40 UTC
*** Bug 706873 has been marked as a duplicate of this bug. ***

Comment 7 Allon Mureinik 2015-01-24 13:10:00 UTC
*** Bug 630655 has been marked as a duplicate of this bug. ***

Comment 8 Allon Mureinik 2015-03-23 09:17:17 UTC
Note to the UXD team:
We want to handle bug 706873 (uploading a VM's DISK, not an ISO) as part of this effort too.

This will probably require slightly different screens.

Comment 9 Einav Cohen 2015-03-23 20:15:42 UTC
Created attachment 1005575 [details]
mock-up: Import Disk

Comment 10 Einav Cohen 2015-03-23 20:22:37 UTC
(In reply to Allon Mureinik from comment #8)
> Note to the UXD team:
> We want to handle bug 706873 (uploading a VM's DISK, not an ISO) as part of
> this effort too.
> 
> This will probably require slightly different screens.

Thanks for the update, Allon. 

After discussing with Liz:

It may make sense to utilize the 'Import' terminology that we are using throughout the application to represent the action of adding a pre-defined item to the system, rather than creating a 'New' one from scratch. 

It would probably make sense to make this action available from the Disks sub-tab of the VMs main tab as well as from the Disks main-tab [see attachment 1005575 [details]]. 

I am not sure if we will have (or already have) capabilities of importing a Disk from e.g. an Export domain - if we do / will, it would make sense to enable this capability from the same button/dialog, and let the user the option to choose whether he wants to Import the Disk from his local file system, from an Export domain, etc. 

If makes completely no sense to use the 'Import' terminology here, I guess that we can use 'Upload' instead (similarly to the action-name for the ISOs - see attachment 923963 [details]). We can also change the terminology for ISOs to 'Import' (though in ISOs, we are never creating new ones from scratch anyway, so a bit of a different case here). 

If you need any further UXD assistance, please feel free to further 'needinfo' us. thanks.

Comment 11 Tony James 2015-05-20 16:10:09 UTC
From the mockup images it appears as though the graphical image/iso uploader will only support NFS paths.  Will http and/or smb also be an option so users can specify a path like http://$host/$file.iso or smb://$user@$host/$file.iso?

It would be nice for users to be able to upload images/isos from their local machines.  Supporting smb and nfs may provide a way to allow this by allowing users to create a share or export on their local machine.

Comment 12 Waldirio M Pinheiro 2015-07-08 04:04:27 UTC
Morning

I was today in a customer and we was testing and comparing environments (RHEV and VMWare) and this point was very important. In VMWare the client can upload/download image, all from webui, without necessity to copy .iso file between machines for example. This will be a great feature in RHEV, the idea is just upload to ISO data store, defining the correct permission, or download if necessary, without necessity to access the server via cli.

Appreciate and let me know if I can help you about it.

B'Regards
Waldirio

Comment 13 Waldirio M Pinheiro 2016-03-08 01:49:46 UTC
Good morning

Would like to ask if are there roadmap for this feature.

Appreciate
Waldirio

Comment 14 Yaniv Lavi 2016-03-09 11:38:38 UTC
(In reply to Waldirio M Pinheiro from comment #13)
> Good morning
> 
> Would like to ask if are there roadmap for this feature.
> 
> Appreciate
> Waldirio

We are planning to add image uploader in the GUI on RHEV 4.0.
ISO uploader is planned later on and requires some infra work which has already started.

Comment 19 Daniel Erez 2017-09-27 11:32:07 UTC
*** Bug 1091377 has been marked as a duplicate of this bug. ***

Comment 21 Raz Tamir 2017-11-09 10:21:55 UTC
No qe_ack:

No feature page available for us to test this feature

Comment 22 RHEL Product and Program Management 2017-11-09 10:22:57 UTC
Quality Engineering Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Comment 23 Yaniv Lavi 2017-11-09 10:55:02 UTC
(In reply to Raz Tamir from comment #21)
> No qe_ack:
> 
> No feature page available for us to test this feature

Please use QE Conditional NAK. Nacking means you are not willing to test and it closes the ticket.

Comment 25 Red Hat Bugzilla Rules Engine 2017-11-21 09:11:33 UTC
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.

Comment 26 Yaniv Lavi 2017-11-27 15:51:37 UTC
Please provide doc text first.

Comment 27 Tal Nisan 2018-01-03 16:56:16 UTC
In order to create an ISO disk container via the REST-API the following should be specified within the request:

<disk>
 ....
 <content_type>iso</content_type>
 ....
</disk>


When the disk exists on an active storage domain in the data center it can be attached to the VM as a CDROM device via the REST-API by sending a POST request to: ....ovirt-engine/api/vms/{vm-id}/cdroms

With the content:

<cdrom>
 <file id="{disk-id}"/>
</cdrom>

Where {disk-id} is the ID of the ISO disk created

Comment 29 Kevin Alon Goldblatt 2018-02-28 15:08:24 UTC
Verified with the following code:
--------------------------------------
ovirt-engine-4.2.2.1-0.1.el7.noarch
vdsm-4.20.19-1.el7ev.x86_64

Verified with the following scenario:
---------------------------------------
Verified with Tier1 for the upload iso part and by verification of https://bugzilla.redhat.com/show_bug.cgi?id=1536826

Moving to VERIFIED

Comment 32 errata-xmlrpc 2018-05-15 17:36:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 33 Franta Kust 2019-05-16 13:05:25 UTC
BZ<2>Jira Resync

Comment 34 Phil Cornelius 2019-05-17 10:27:30 UTC
Hi

This does not solve the problem for 'Boot Options' where I can specify a kernel and initrd using iso:// style path

This will become more of an issue when booting up RH coreos using ignite config. To automate this we would need to be able to pass kernel params pointing at bios or uefi image and .ign config

At the moment I cannot upload a kernel image and initrd to the ISO Domain via rest or the web UI.

Thanks
Phil

Comment 35 John Call 2019-05-17 10:35:54 UTC
To add on to what Phil said, if the kernel/initrd were uploaded to a "data" domain, the VMs can't boot from them.


Note You need to log in before you can comment on or make changes to this bug.