Bug 1306664 - RemoteBox-1.9-5.fc24 FTBFS: tag-missing: <translation> not specified
RemoteBox-1.9-5.fc24 FTBFS: tag-missing: <translation> not specified
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libappstream-glib (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
https://sourceforge.net/p/remotebox/t...
: FutureFeature, NeedsTestCase
: 1307299 1313279 (view as bug list)
Depends On:
Blocks: F24FTBFS 1242140
  Show dependency treegraph
 
Reported: 2016-02-11 09:36 EST by Petr Pisar
Modified: 2016-04-06 10:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-06 10:07:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-02-11 09:36:58 EST
RemoteBox-1.9-5.fc24 fails to build in F24 because tests fails:

+ appstream-util validate --nonet /builddir/build/BUILDROOT/RemoteBox-1.9-5.fc24.noarch/usr/share/appdata/remotebox.appdata.xml
/builddir/build/BUILDROOT/RemoteBox-1.9-5.fc24.noarch/usr/share/appdata/remotebox.appdata.xml: GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
FAILED:
? tag-missing           : <translation> not specified
Validation of files failed

Difference between working and failing build root:

        libappstream-glib 	0.5.6-1.fc24 	> 	0.5.8-1.fc24
	coreutils 	8.24-108.fc24 	> 	8.25-2.fc24
	libgcc 	6.0.0-0.7.fc24 	> 	6.0.0-0.8.fc24
	coreutils-common 	8.24-108.fc24 	> 	8.25-2.fc24
	libstdc++ 	6.0.0-0.7.fc24 	> 	6.0.0-0.8.fc24
	libsolv 	0.6.15-5.fc24 	> 	0.6.15-6.fc24
	rpm-libs 	4.13.0-0.rc1.19.fc24 	> 	4.13.0-0.rc1.22.fc24
	kernel-headers 	4.5.0-0.rc1.git2.1.... 	> 	4.5.0-0.rc2.git0.1....
	python3-setuptools 	19.6-1.fc24 	> 	19.6.2-1.fc24
	libreport-filesystem 	2.6.3-2.fc24 	> 	2.6.4-1.fc24
	rpm-plugin-selinux 	4.13.0-0.rc1.19.fc24 	> 	4.13.0-0.rc1.22.fc24
	cpp 	6.0.0-0.7.fc24 	> 	6.0.0-0.8.fc24
	libstdc++-devel 	6.0.0-0.7.fc24 	> 	6.0.0-0.8.fc24
	redhat-rpm-config 	39-1.fc24 	> 	40-1.fc24
	gcc 	6.0.0-0.7.fc24 	> 	6.0.0-0.8.fc24
	rpm 	4.13.0-0.rc1.19.fc24 	> 	4.13.0-0.rc1.22.fc24
	rpm-build-libs 	4.13.0-0.rc1.19.fc24 	> 	4.13.0-0.rc1.22.fc24
	gdb 	7.10.50.20160121-46.fc24 	> 	7.10.50.20160131-50.fc24
	rpm-plugin-systemd-inhibit 	4.13.0-0.rc1.19.fc24 	> 	4.13.0-0.rc1.22.fc24
	gcc-c++ 	6.0.0-0.7.fc24 	> 	6.0.0-0.8.fc24
	gcc-gdb-plugin 	6.0.0-0.7.fc24 	> 	6.0.0-0.8.fc24
	libgomp 	6.0.0-0.7.fc24 	> 	6.0.0-0.8.fc24
	rpm-python3 	4.13.0-0.rc1.19.fc24 	> 	4.13.0-0.rc1.22.fc24
	rpm-build 	4.13.0-0.rc1.19.fc24 	> 	4.13.0-0.rc1.22.fc24
Comment 1 Petr Pisar 2016-02-17 07:11:06 EST
*** Bug 1307299 has been marked as a duplicate of this bug. ***
Comment 2 Yaakov Selkowitz 2016-02-19 13:45:06 EST
Culprit is definitely libappstream-glib; support for the <translation> tag was just added in 0.5.8:

https://github.com/hughsie/appstream-glib/commit/cef24105dd7466fa9f872d6857ad3b3a560a43c1

It shouldn't be mandatory though, and RemoteBox isn't translated.
Comment 3 Jan Kurik 2016-02-24 09:30:05 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 4 Fedora Admin XMLRPC Client 2016-02-26 12:40:18 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2016-02-29 09:27:58 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Raphael Groner 2016-03-02 03:05:15 EST
*** Bug 1313279 has been marked as a duplicate of this bug. ***
Comment 7 Raphael Groner 2016-03-03 10:25:38 EST
Violation of packaging guidelines:

 app-data-validate usage

Although you can just include the .appdata.xml file in the package, you MUST run appstream-util validate-relax (in %check or %install) and have BuildRequires: libappstream-glib, to help ensure .appdata.xml file safety and spec-compliance. Here are some examples of usage:

appstream-util validate-relax --nonet %{buildroot}/%{_datadir}/appdata/*.appdata.xml


https://fedoraproject.org/wiki/Packaging:AppData#app-data-validate_usage
Comment 8 Raphael Groner 2016-03-25 07:57:36 EDT
Version 2.0 is FTBFS also, see bug #1242140.

+ appstream-util validate --nonet /builddir/build/BUILDROOT/RemoteBox-2.0-1.fc25.x86_64/usr/share/appdata/remotebox.appdata.xml
/builddir/build/BUILDROOT/RemoteBox-2.0-1.fc25.x86_64/usr/share/appdata/remotebox.appdata.xml: GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
FAILED:
? tag-missing           : <translation> not specified
Validation of files failed
Comment 9 Raphael Groner 2016-03-25 07:59:26 EDT
(In reply to Yaakov Selkowitz from comment #2)
> Culprit is definitely libappstream-glib; support for the <translation> tag
> was just added in 0.5.8:
> 
> https://github.com/hughsie/appstream-glib/commit/
> cef24105dd7466fa9f872d6857ad3b3a560a43c1
> 
> It shouldn't be mandatory though, and RemoteBox isn't translated.

Reassigning so to libappstream-glib to ask for clarification if this bug is more general.
Comment 10 Richard Hughes 2016-04-01 11:18:39 EDT
for an app with no translation (is that right?!) <translation/> should make the validation error go away, right?
Comment 11 Raphael Groner 2016-04-01 14:12:25 EDT
(In reply to Richard Hughes from comment #10)
> for an app with no translation (is that right?!) <translation/> should make
> the validation error go away, right?

Thanks. That fixed it.
Comment 12 Fedora Update System 2016-04-01 15:23:03 EDT
RemoteBox-2.0-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b313538a67
Comment 13 Fedora Update System 2016-04-02 01:24:17 EDT
RemoteBox-2.0-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b313538a67
Comment 14 Fedora Update System 2016-04-06 10:07:02 EDT
RemoteBox-2.0-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.