Bug 1306820 - [RFE] Validate NFS during RHEV configuration, rather than at Review
[RFE] Validate NFS during RHEV configuration, rather than at Review
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 1.0
Assigned To: Dylan Murray
Thom Carlin
: FutureFeature, Triaged
Depends On:
Blocks: qci-sprint-17
  Show dependency treegraph
 
Reported: 2016-02-11 14:12 EST by Matt Reid
Modified: 2016-09-13 12:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:26:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2016-02-11 14:12:19 EST
Description of problem:
It's great that we can validate the NFS settings before trying to deploy to it, but it would make more sense if we were able to do that at the end of the RHEV steps, rather than waiting until the end, during the Review stage.

The information would be fresher in their mind, and they would be right there where they need to be to fix anything that might be wrong in their configuration, rather than assuming they're all set (since nothing said otherwise during configuration), hitting Review, and finding out they have to go back and fix their NFS config before they can actually start deploying.

Additional info:
Comment 2 Dylan Murray 2016-06-10 00:35:20 EDT
Previous PR was closed for this one.

https://github.com/fusor/fusor/pull/941

Storage mounts will now be validated before continuing on past RHEV configuration.
Comment 3 John Matthews 2016-06-23 16:01:18 EDT
Addressed in ISO Set:
QCI-1.2-RHEL-7-20160623.t.0-QCI-x86_64-dvd1.iso
QCIOOO-8.0-RHEL-7-20160623.t.0-QCIOOO-x86_64-dvd1.iso
Comment 4 Thom Carlin 2016-06-24 08:19:29 EDT
Failed, was able to specify Storage Address of "foo" and Share Path of "/bar" and proceed past RHEV steps.
Comment 5 Dylan Murray 2016-07-05 10:10:59 EDT
https://github.com/fusor/fusor/pull/1000

Assuming this failed QA due to no validations on self hosted share. I have confirmed all NFS shares are being validated on the RHEV configuration screen with this PR.
Comment 6 John Matthews 2016-07-18 17:12:41 EDT
QCI-1.2-RHEL-7-20160718.t.0
Comment 11 bmorriso 2016-08-25 15:14:51 EDT
Verified in compose QCI-1.0-RHEL-7-20160824.t.1

Validation of NFS shares now occurs at the RHEV Storage configuration page, checking that they can be mounted and that the shares are empty.
Comment 13 errata-xmlrpc 2016-09-13 12:26:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.