Bug 1306833 - cannot trigger VM retirement via API
cannot trigger VM retirement via API
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Tim Wade
Martin Kourim
rest:retirement
: Reopened, ZStream
Depends On:
Blocks: 1309746
  Show dependency treegraph
 
Reported: 2016-02-11 15:21 EST by Colin Arnott
Modified: 2016-11-07 23:00 EST (History)
10 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1309746 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:41:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Arnott 2016-02-11 15:21:39 EST
Description of problem:
you cannot triger retirement via an API call; service retirement can be trigger it via an API call and can result in the retirement of a VM, however without a service one would need to instantiate an automate model and interact with the automate APIs in order to directly retire a VM.

Version-Release number of selected component (if applicable):
cfme-5.5.2.4-1.el7cf.x86_64

Additional info:
this bug is requesting that there be an API created that allows one to trigger retirement by interacting with a VM object
Comment 2 Tim Wade 2016-02-15 11:04:41 EST
Colin,

You can retire a vm with the following API call:

POST /api/vms/:id

{
  "action": "retire"
}

Please let me know if that doesn't meet your needs.

Thanks,
Tim
Comment 3 Colin Arnott 2016-02-16 10:38:04 EST
This looks like what we would like. Thanks for the info.
Comment 6 Dave Johnson 2016-02-18 13:04:33 EST
Tim/Colin,  if we can cleanly merge this to downstream 5.5.z, then there is no reason to wait.
Comment 9 Joe Rafaniello 2016-02-19 14:45:18 EST
This was fixed upstream in https://github.com/ManageIQ/manageiq/pull/5718
Comment 11 Taras Lehinevych 2016-04-27 06:57:08 EDT
Verified in 5.6.0.4-beta2.3
Comment 13 errata-xmlrpc 2016-06-29 11:41:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.