Bug 1306835 - During retirement the user that started the retirement should be stored as userid not user_id
During retirement the user that started the retirement should be stored as us...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.4.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.6.0
Assigned To: mkanoor
Shveta
: ZStream
Depends On:
Blocks: 1308691 1308692
  Show dependency treegraph
 
Reported: 2016-02-11 15:25 EST by mkanoor
Modified: 2016-07-12 14:46 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1308691 1308692 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:41:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mkanoor 2016-02-11 15:25:46 EST
Description of problem:
During retirement the userid of the user that started the retirement should be stored as userid and not as user_id.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. During retirement use an automate method
    to check $evm.root['userid']
2.
3.

Actual results:
user_id is set

Expected results:
userid should be set

Additional info:
user_id in RAILS means the ID of the user object. The USER table has a column called userid which is different from the ID. We are trying to store the userid and not the ID of the user.
Comment 2 CFME Bot 2016-02-11 17:00:41 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/979e0c4e4ad12ecf2568cc541cbeec073314a1d0

commit 979e0c4e4ad12ecf2568cc541cbeec073314a1d0
Author:     Madhu Kanoor <mkanoor@redhat.com>
AuthorDate: Thu Feb 11 16:06:32 2016 -0500
Commit:     Madhu Kanoor <mkanoor@redhat.com>
CommitDate: Thu Feb 11 16:06:32 2016 -0500

    user_id should be userid
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1306835
    
    During retirement the userid of the inititator should be stored
    as userid and not as user_id.

 app/models/mixins/retirement_mixin.rb                         | 2 +-
 spec/models/orchestration_stack/retirement_management_spec.rb | 2 +-
 spec/models/service/retirement_management_spec.rb             | 2 +-
 spec/models/vm/retirement_management_spec.rb                  | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)
Comment 3 mkanoor 2016-02-11 17:31:53 EST
We should change the documentation to indicate this change.
Comment 6 CFME Bot 2016-02-16 12:20:14 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=c14044fa9760e901a08d1c2864b57847c802e36b

commit c14044fa9760e901a08d1c2864b57847c802e36b
Author:     Madhu Kanoor <mkanoor@redhat.com>
AuthorDate: Thu Feb 11 16:06:32 2016 -0500
Commit:     Madhu Kanoor <mkanoor@redhat.com>
CommitDate: Mon Feb 15 14:15:12 2016 -0500

    user_id should be userid
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1306835
    
    During retirement the userid of the inititator should be stored
    as userid and not as user_id.

 vmdb/app/models/mixins/retirement_mixin.rb             | 2 +-
 vmdb/spec/models/service/retirement_management_spec.rb | 2 +-
 vmdb/spec/models/vm/retirement_management_spec.rb      | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)
Comment 7 CFME Bot 2016-02-19 19:46:37 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=ab77fc24ee9019df8b1f50a55f853e34b77630ac

commit ab77fc24ee9019df8b1f50a55f853e34b77630ac
Author:     Madhu Kanoor <mkanoor@redhat.com>
AuthorDate: Thu Feb 11 16:06:32 2016 -0500
Commit:     Madhu Kanoor <mkanoor@redhat.com>
CommitDate: Fri Feb 19 15:54:49 2016 -0500

    user_id should be userid
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1306835
    
    During retirement the userid of the inititator should be stored
    as userid and not as user_id.

 app/models/mixins/retirement_mixin.rb                         | 2 +-
 spec/models/orchestration_stack/retirement_management_spec.rb | 2 +-
 spec/models/service/retirement_management_spec.rb             | 2 +-
 spec/models/vm/retirement_management_spec.rb                  | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)
Comment 8 Shveta 2016-04-19 01:17:00 EDT
Retirement initiator is stored as userid not as user_id.
Verified in 5.6.0.1-beta2.20160413141124_e25ac0e
Comment 10 errata-xmlrpc 2016-06-29 11:41:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.