Bug 1308691 - During retirement the user that started the retirement should be stored as userid not user_id
During retirement the user that started the retirement should be stored as us...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.4.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.5.3
Assigned To: mkanoor
Milan Falešník
: ZStream
Depends On: 1306835 1308692
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 13:36 EST by Chris Pelland
Modified: 2017-08-29 21:19 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1306835
Environment:
Last Closed: 2016-04-13 14:43:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 CFME Bot 2016-02-19 19:46:33 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=f77ca1ee1987861f36278711420d1e6258b9f3f7

commit f77ca1ee1987861f36278711420d1e6258b9f3f7
Merge: 59cd84d ab77fc2
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Fri Feb 19 19:43:37 2016 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Fri Feb 19 19:43:37 2016 -0500

    Merge branch 'bugzilla_1308691_5_5_z' into '5.5.z'
    
    During retirement the user that started the retirement should be stored as userid not as user_id
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1308691
    
    During retirement the userid of the inititator should be stored
    as userid and not as user_id.
    
    Original PR: https://github.com/ManageIQ/manageiq/pull/6633
    Clean Cherry Pick
    
    See merge request !793

 app/models/mixins/retirement_mixin.rb                         | 2 +-
 spec/models/orchestration_stack/retirement_management_spec.rb | 2 +-
 spec/models/service/retirement_management_spec.rb             | 2 +-
 spec/models/vm/retirement_management_spec.rb                  | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)
Comment 3 Milan Falešník 2016-03-29 11:26:58 EDT
Verified in 5.5.3.2, the $evm.root['userid'] is set in the context ov VM Retirement AE workflow.
Comment 5 errata-xmlrpc 2016-04-13 14:43:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.