Bug 1306848 - Refactor Red Hat Access Client JS to Proxy through Satellite
Refactor Red Hat Access Client JS to Proxy through Satellite
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: rubygem-foreman-redhat_access (Show other bugs)
Unspecified
All All
high Severity high (vote)
: Unspecified
: --
Assigned To: Lindani Phiri
Katello QA List
: Triaged
Depends On:
Blocks: 1306849
  Show dependency treegraph
 
Reported: 2016-02-11 16:44 EST by Keith Robertson
Modified: 2017-02-23 14:38 EST (History)
5 users (show)

See Also:
Fixed In Version: ruby193-rubygem-foreman-redhat_access-0.2.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1306849 (view as bug list)
Environment:
Last Closed: 2016-11-15 08:51:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Robertson 2016-02-11 16:44:22 EST
Remove the CORS dependency in the Red Hat Access client JS and proxy all calls to the Red Hat Customer Portal through the Satellite 6 server.  

This is necessary because CORS support will be disabled in the Customer Portal soon and without this change the plug-in will stop functioning.
Comment 5 Mike McCune 2016-03-28 18:57:02 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Note You need to log in before you can comment on or make changes to this bug.