Bug 1306849 - Refactor Red Hat Access Client JS to Proxy through Satellite
Refactor Red Hat Access Client JS to Proxy through Satellite
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: rubygem-foreman-redhat_access (Show other bugs)
Unspecified
All All
high Severity high (vote)
: Beta
: --
Assigned To: Katello Bug Bin
jcallaha
: Triaged
Depends On: 1306848
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-11 16:46 EST by Keith Robertson
Modified: 2016-07-27 05:23 EDT (History)
6 users (show)

See Also:
Fixed In Version: tfm-rubygem-foreman-redhat_access-1.0.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1306848
Environment:
Last Closed: 2016-07-27 05:23:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Robertson 2016-02-11 16:46:21 EST
Cloning this BZ for 6.2.0

+++ This bug was initially created as a clone of Bug #1306848 +++

Remove the CORS dependency in the Red Hat Access client JS and proxy all calls to the Red Hat Customer Portal through the Satellite 6 server.  

This is necessary because CORS support will be disabled in the Customer Portal soon and without this change the plug-in will stop functioning.
Comment 4 jcallaha 2016-04-14 14:31:19 EDT
Verified in Satellite 6.2 Beta Snap 8 Compose 1.
Comment 8 errata-xmlrpc 2016-07-27 05:23:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.