Bug 1306887 - [Nimble Storage] Add APTPL flag to fence_mpath and make multipath-tools honor APTPL bit on registrations
[Nimble Storage] Add APTPL flag to fence_mpath and make multipath-tools honor...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
6.7
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Ben Marzinski
Lin Li
:
Depends On:
Blocks: 1498724
  Show dependency treegraph
 
Reported: 2016-02-11 20:40 EST by shivamerla1
Modified: 2017-10-05 00:47 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1498724 (view as bug list)
Environment:
Last Closed: 2017-10-05 00:47:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shivamerla1 2016-02-11 20:40:15 EST
Description of problem:
Currently fence-mpath agent doesn't support "Activate Persist Through Power Loss" flag. Due to this SCSI-3 persistent registrations/reservations are not persistent across array power loss.

Also, multipath-tools currently not honoring APTPL bit set by mpathpersist. If the path goes to faulty and running again, it will register_and_ignore without APTPL flag.

Hence the supported needs to be added to both multipath-tools and fence-mpath agent.

Version-Release number of selected component (if applicable):
fence-agents-4.0.15-8.el6_7.2.x86_64
[root@~]# uname -r
2.6.32-573.12.1.el6.x86_64

[root@~]# rpm -qa | grep multipath
device-mapper-multipath-libs-0.4.9-87.el6.x86_64
device-mapper-multipath-0.4.9-87.el6.x86_64

How reproducible:
Consistent

Steps to Reproduce:
1. Register key using APTPL param to mpathpersist/fence-mpath agent.
2. Reboot array controller.
3. SCSI-3 Reservation/Registrations are not persisted.

Actual results:
SCSI-3 Reservation/Registrations are not persisted after array power loss.

Expected results:
Should have persisted with APTPL bit.

Additional info:
Comment 2 Lin Li 2016-02-16 01:27:25 EST
Hello shivamerla1,
Because there is no Nimble Storage in our lab, could you help provide test result once the package is available?
thanks!
Comment 3 shivamerla1 2016-02-16 01:58:25 EST
Sure, we can help testing the fix.
Comment 5 Ben Marzinski 2017-10-05 00:47:14 EDT
This doesn't work in RHEL7, and it makes much more sense to fix it there. I've cloned the bug for RHEL7, and I'm closing this one.

Note You need to log in before you can comment on or make changes to this bug.