Bug 1498724 - [Nimble Storage] Add APTPL flag to fence_mpath and make multipath-tools honor APTPL bit on registrations
Summary: [Nimble Storage] Add APTPL flag to fence_mpath and make multipath-tools honor...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath   
(Show other bugs)
Version: 7.6
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: Lin Li
Marek Suchanek
URL:
Whiteboard:
Keywords:
Depends On: 1306887
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-05 04:45 UTC by Ben Marzinski
Modified: 2018-10-30 11:28 UTC (History)
12 users (show)

Fixed In Version: device-mapper-multipath-0.4.9-120.el7
Doc Type: Bug Fix
Doc Text:
*multipathd* can now correctly set APTPL when registering keys on path devices Previously, the *multipathd* service did not track which devices registered their persistent reservation keys with the Activate Persist Through Power Loss (APTPL) option. As a consequence, registrations always lost the APTPL setting. With this update, the problem has been fixed: * If you set the "reservation_key" option to a file in the `multipath.conf` configuration file, *multipathd* now keeps the APTPL setting automatically. * If you set "reservation_key" to a specific key, you can now add the ":aptpl" string at the end of the key in "reservation_key", which enables APTPL for it. Set this to match the APTPL setting used when registering the key.
Story Points: ---
Clone Of: 1306887
Environment:
Last Closed: 2018-10-30 11:27:28 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3236 None None None 2018-10-30 11:28 UTC

Comment 2 Lin Li 2018-04-08 03:21:55 UTC
Hello shivamerla1,
Because there is no Nimble Storage in our lab, could you help provide test result once the package is available?
thanks!

Comment 4 Ben Marzinski 2018-06-13 14:29:09 UTC
Multipath now supports an optional extension to the reservation_key parameter. You can now set reservation_key to "<key>:aptpl".  This will inform multipathd to set the APTPL bit when registering keys on paths, when they come back up. For this to work correctly, you must also set --param-aptpl when using mpathpersist to register the key. If you set reservation_key to "file", multipath will automatically track which devices need the APTPL bit set by multipathd, depending on which devices you register keys with using the --param-aptpl option
for mpathpersist.

Comment 6 Lin Li 2018-08-22 09:14:03 UTC
Hi shivamerla1,
Could you test if the new option works well on Nimble Storage? 
Thanks in advance!

Comment 14 errata-xmlrpc 2018-10-30 11:27:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3236


Note You need to log in before you can comment on or make changes to this bug.