Bug 1307006 - lximage-qt: FTBFS in rawhide cause of grep 2.23
lximage-qt: FTBFS in rawhide cause of grep 2.23
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lximage-qt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Helio Chissini de Castro
Fedora Extras Quality Assurance
https://apps.fedoraproject.org/kosche...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 07:32 EST by Raphael Groner
Modified: 2016-02-16 13:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 13:19:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (56.52 KB, text/plain)
2016-02-12 07:32 EST, Raphael Groner
no flags Details

  None (edit)
Description Raphael Groner 2016-02-12 07:32:41 EST
Created attachment 1123481 [details]
build.log

Description of problem:
Package lximage-qt fails to build from source in rawhide.

Version-Release number of selected component (if applicable):
0.4.0-5.fc24

Steps to Reproduce:
koji build --scratch f24 lximage-qt-0.4.0-5.fc24.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://apps.fedoraproject.org/koschei/package/lximage-qt

Interesting part of build.log (see attachment for complete log):
+ /usr/lib/rpm/find-lang.sh /builddir/build/BUILDROOT/lximage-qt-0.4.0-5.fc24.x86_64 lximage-qt --with-qt
+ for desktop in '/builddir/build/BUILDROOT/lximage-qt-0.4.0-5.fc24.x86_64//usr/share/applications/*.desktop'
+ desktop-file-edit --remove-category=LXQt --remove-only-show-in=LXQt --add-only-show-in=X-LXQt /builddir/build/BUILDROOT/lximage-qt-0.4.0-5.fc24.x86_64//usr/share/applications/lximage-qt-screenshot.desktop
Error on file "/builddir/build/BUILDROOT/lximage-qt-0.4.0-5.fc24.x86_64//usr/share/applications/lximage-qt-screenshot.desktop": Key file contains line 'Binary file /builddir/build/BUILD/lximage-qt-0.4.0/src/translations/lximage-qt-screenshot_pt.desktop matches' which is not a key-value pair, group, or comment
Comment 1 Raphael Groner 2016-02-12 07:33:26 EST
*** Bug 1305999 has been marked as a duplicate of this bug. ***
Comment 2 Raphael Groner 2016-02-12 07:35:51 EST
As already detected in bug #1305999, a new grep version is responsible for this bug and should be fixed in liblxqt, reassigning again.
Comment 3 Raphael Groner 2016-02-12 09:08:39 EST
Taking back. lximage-qt has its own cmake/LXQtTranslateDesktop.cmake, that should be replaced with the global cmake file from liblxqt-devel.
Comment 4 Raphael Groner 2016-02-14 09:41:03 EST
Requested upstream to unbundle the cmake module.
https://github.com/lxde/lximage-qt/issues/50
Comment 5 Raphael Groner 2016-02-15 12:44:32 EST
Helio, as said in IRC. It would be great if you can fix. The upstream PR needs some rebase to version 0.4.0 as we currently have for the package.

https://github.com/lxde/lximage-qt/commit/c7f58e9689082325770a4040fd0dc590580ab652
Comment 6 Upstream Release Monitoring 2016-02-15 17:19:49 EST
heliocastro's lximage-qt-0.4.0-6.fc24 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=736206

Note You need to log in before you can comment on or make changes to this bug.