Bug 1305999 - lxqt-common: FTBFS in rawhide cause of grep 2.23
lxqt-common: FTBFS in rawhide cause of grep 2.23
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: liblxqt (Show other bugs)
rawhide
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Helio Chissini de Castro
Fedora Extras Quality Assurance
https://apps.fedoraproject.org/kosche...
: Reopened
: 1306001 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 14:16 EST by Raphael Groner
Modified: 2016-02-14 13:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-12 07:33:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (56.69 KB, text/plain)
2016-02-09 14:16 EST, Raphael Groner
no flags Details

  None (edit)
Description Raphael Groner 2016-02-09 14:16:24 EST
Created attachment 1122501 [details]
build.log

Description of problem:
Package lximage-qt fails to build from source in rawhide.

Version-Release number of selected component (if applicable):
0.4.0-5.fc24

Steps to Reproduce:
koji build --scratch f24 lximage-qt-0.4.0-5.fc24.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://apps.fedoraproject.org/koschei/package/lximage-qt

Relevant part of build.log (see attachment for full log):
+ for desktop in '/builddir/build/BUILDROOT/lximage-qt-0.4.0-5.fc24.i386//usr/share/applications/*.desktop'
+ desktop-file-edit --remove-category=LXQt --remove-only-show-in=LXQt --add-only-show-in=X-LXQt /builddir/build/BUILDROOT/lximage-qt-0.4.0-5.fc24.i386//usr/share/applications/lximage-qt-screenshot.desktop
Error on file "/builddir/build/BUILDROOT/lximage-qt-0.4.0-5.fc24.i386//usr/share/applications/lximage-qt-screenshot.desktop": Key file contains line 'Binary file /builddir/build/BUILD/lximage-qt-0.4.0/src/translations/lximage-qt-screenshot_pt.desktop matches' which is not a key-value pair, group, or comment
Comment 1 Raphael Groner 2016-02-09 16:01:25 EST
Reproducible. Moving over to desktop-file-utils as there are or may be more packages affected. Is it somehow related to the gcc6 rebuild?
Comment 2 Raphael Groner 2016-02-09 16:03:53 EST
*** Bug 1306001 has been marked as a duplicate of this bug. ***
Comment 3 Raphael Groner 2016-02-09 16:44:48 EST
+ for desktop in '/builddir/build/BUILDROOT/lxqt-common-0.10.0-8.fc24.noarch/etc/xdg/autostart/*.desktop'
/builddir/build/BUILDROOT/lxqt-common-0.10.0-8.fc24.noarch/etc/xdg/autostart/lxqt-compton.desktop
+ echo /builddir/build/BUILDROOT/lxqt-common-0.10.0-8.fc24.noarch/etc/xdg/autostart/lxqt-compton.desktop
+ cat /builddir/build/BUILDROOT/lxqt-common-0.10.0-8.fc24.noarch/etc/xdg/autostart/lxqt-compton.desktop
[Desktop Entry]
Type=Application
Name=Compton (X Compositor)
GenericName=X compositor
Comment=A X compositor
TryExec=compton
Exec=compton --dbus
# turned off by default
Hidden=true
OnlyShowIn=LXQt;
X-LXQt-Module=true
Name[de]=Compton (X11 Kompositionsmanager)
GenericName[de]=X11 Kompositionsmanager
Binary file /builddir/build/BUILD/lxqt-common-0.10.0/autostart/translations/lxqt-compton_de.desktop matches
Binary file /builddir/build/BUILD/lxqt-common-0.10.0/autostart/translations/lxqt-compton_el.desktop matches
Name[pt]=Compton (Compositor X)
GenericName[pt]=Compositor X
Comment[pt]=Compositor para o servidor X
RPM build errors:
+ desktop-file-edit --remove-only-show-in=LXQt --add-only-show-in=X-LXQt /builddir/build/BUILDROOT/lxqt-common-0.10.0-8.fc24.noarch/etc/xdg/autostart/lxqt-compton.desktop
Error on file "/builddir/build/BUILDROOT/lxqt-common-0.10.0-8.fc24.noarch/etc/xdg/autostart/lxqt-compton.desktop": Key file contains line 'Binary file /builddir/build/BUILD/lxqt-common-0.10.0/autostart/translations/lxqt-compton_de.desktop matches' which is not a key-value pair, group, or comment

see http://koji.fedoraproject.org/koji/taskinfo?taskID=12917666
Comment 4 Rex Dieter 2016-02-09 17:04:37 EST
I think it comes down to 
/usr/share/cmake/lxqt/modules/LXQtTranslateDesktop.cmake
from liblxqt-devel

For some reason the lxqt_translate_desktop function there is producing bad output on rawhide.
Comment 5 Rex Dieter 2016-02-09 17:16:31 EST
My best guess: the calls to grep are failing now with rawhide's grep-2.23, maybe liblxqt should use 'grep -a' or 'grep --text' to force it to assume text input
Comment 6 Rex Dieter 2016-02-09 17:37:07 EST
Let's see if that helps
http://koji.fedoraproject.org/koji/taskinfo?taskID=12918298
Comment 7 Rex Dieter 2016-02-09 18:43:50 EST
https://koji.fedoraproject.org/koji/taskinfo?taskID=12918468

that did the trick.
Comment 8 Raphael Groner 2016-02-10 04:41:56 EST
Thank you!
Comment 9 Raphael Groner 2016-02-12 07:29:44 EST
This bug still exists for lximage-qt, since the new grep version was introduced into rawhide.
Comment 10 Raphael Groner 2016-02-12 07:33:26 EST

*** This bug has been marked as a duplicate of bug 1307006 ***
Comment 11 Raphael Groner 2016-02-14 09:34:49 EST
For the record, they've fixed it upstream:
https://github.com/lxde/liblxqt/commit/082321a1a513b5fb694ca60e368eddd57b58f433

Note You need to log in before you can comment on or make changes to this bug.