Bug 1307016 - Satellite Option to merge virt-who reported rhev/kvm hypevisor and content host where the hypervisor is running
Satellite Option to merge virt-who reported rhev/kvm hypevisor and content ho...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.1.6
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: Tom McKay
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 08:06 EST by Stefan Nemeth
Modified: 2017-10-23 08:30 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-02 12:09:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Nemeth 2016-02-12 08:06:22 EST
Description of problem:

virt-who reports rhev/kvm hypervisor which is running on rhel. In order to get rhel rhev server registered to satellite to also work as content host, new entry is created. There are two entires, one for hypervisor, one for content host where the rhev is running one for hypervisor.



How reproducible:

100%

Steps to Reproduce:
1. install satellite, rhel server with rhev and virt-who machine
2. register rhel rhev server to satellite


Actual results:

entry for hypervisor
entry for content host

Expected results:

option to merge content host and hypervisor to one entry. 


Additional info:
Comment 5 Rich Jerrido 2016-05-16 16:10:50 EDT
tl;dr version - you don't have to use the rhevm virt-who config if you are using RHEL as a hypervisor. 

RHEV Supports two types of hypervisors:

* a RHEL system with packages from the 'rhel-7-server-rhev-mgmt-agent-rpms' repo. 
* RHEV-H (https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html-single/Installation_Guide/index.html#Installing_the_Red_Hat_Enterprise_Virtualization_Hypervisor)

The former is a standard RHEL system, that is registered via subscription-manager to the Satellite. 

The latter is an read-only appliance installation of RHEL that is NOT expected to be registered via the Satellite. 

This 'bug' (if you wish to call it that) occurs because the (RHEL) hypervisor is being reported to Satellite twice (once via its subscription-manager registration and again via virt-who in the rhevm configuration). 

For a given hostname, it is expected that the user sets up:

* virt-who on the hypervisors with kvm/qemu mode (for RHEL hypervisors) OR
* virt-who in RHEV-M mode (for RHEV-H hypervisors)

But NEVER both.

For RHEL hypervisors, as they are registered to the Satellite, all that is needed is to install virt-who on EACH hypervisor and configure it as such. 

# egrep -v '(^#|^$)' /etc/sysconfig/virt-who
VIRTWHO_DEBUG=0
VIRTWHO_SATELLITE6=1
VIRTWHO_LIBVIRT=1 


For RHEV-H hypervisors, it is expected to configure virt-who  (man 5 virt-who-config) with the rhevm mode. 

The only caveat is when the customer is running BOTH RHEL AND RHEV-H hypervisors, you'd have to configure the virt-who instance running in rhevm mode to NOT report the RHEL hypervisors (which can be done via the filter_host_uuids directive - again see man 5 virt-who-config). I do not know how common this configuration is (mixed RHEL & RHEV-H environments). Possibly the RHEV engineers (on rhev-tech@) would know. 

I would assert that using virt-who to report the same hypervisor into the same organization via differing means is a misconfiguration. However, if it is determined based upon the prevalence of mixed RHEL/RHEV-H environments to fix this misconfiguration by somehow linking the two entries (if possible), that would satisfy this request.
Comment 15 Bryan Kearney 2016-07-26 11:25:24 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 16 Bryan Kearney 2016-07-26 11:36:11 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 18 Tom McKay 2016-08-02 12:09:37 EDT
The following doc BZ should cover this scenario

https://bugzilla.redhat.com/show_bug.cgi?id=1348724

Note You need to log in before you can comment on or make changes to this bug.