Bug 1307208 - dht: NULL layouts referenced while the I/O is going on tiered volume
dht: NULL layouts referenced while the I/O is going on tiered volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nithya Balachandran
Tiering
:
Depends On: 1305858
Blocks: 1308400
  Show dependency treegraph
 
Reported: 2016-02-12 23:29 EST by Nithya Balachandran
Modified: 2016-06-16 09:57 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1305858
: 1308400 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:57:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-13 00:17:33 EST
REVIEW: http://review.gluster.org/13440 (cluster/dht: Skip subvols if no layout present) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 2 Vijay Bellur 2016-02-13 00:30:02 EST
REVIEW: http://review.gluster.org/13440 (cluster/dht: Skip subvols if no layout present) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 3 Vijay Bellur 2016-02-14 23:37:36 EST
COMMIT: http://review.gluster.org/13440 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit bfd8f92490454f261330da34565334ed5decd0e1
Author: N Balachandran <nbalacha@redhat.com>
Date:   Sat Feb 13 10:02:55 2016 +0530

    cluster/dht: Skip subvols if no layout present
    
    Running "rm -rf" on a tiered volume sometimes caused
    the client to crash because dht_readdirp_cbk referenced
    a NULL layout for the hot tier subvol.
    Now, entries are skipped if the layout is NULL. This
    can cause "rm -rf" to fail with ENOTEMPTY rmdir failures.
    
    Change-Id: Idd71a9d0f7ee712899cc7113bbf2cd3dcb25808b
    BUG: 1307208
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/13440
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:57:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.