Bug 1308400 - dht: NULL layouts referenced while the I/O is going on tiered volume
Summary: dht: NULL layouts referenced while the I/O is going on tiered volume
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.7.7
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard: Tiering
Depends On: 1305858 1307208
Blocks: glusterfs-3.7.9
TreeView+ depends on / blocked
 
Reported: 2016-02-15 04:55 UTC by Nithya Balachandran
Modified: 2016-04-19 07:24 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Clone Of: 1307208
Environment:
Last Closed: 2016-04-19 07:24:46 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-02-15 05:03:41 UTC
REVIEW: http://review.gluster.org/13441 (cluster/dht: Skip subvols if no layout present) posted (#1) for review on release-3.7 by N Balachandran (nbalacha@redhat.com)

Comment 2 Vijay Bellur 2016-02-22 02:37:11 UTC
COMMIT: http://review.gluster.org/13441 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit e5c24b4040d1fe11d92194b4e2277e0587f85e2e
Author: N Balachandran <nbalacha@redhat.com>
Date:   Mon Feb 15 10:24:05 2016 +0530

    cluster/dht: Skip subvols if no layout present
    
    Running "rm -rf" on a tiered volume sometimes caused
    the client to crash because dht_readdirp_cbk referenced
    a NULL layout for the hot tier subvol.
    Now, entries are skipped if the layout is NULL. This
    can cause "rm -rf" to fail with ENOTEMPTY rmdir failures.
    
    > Change-Id: Idd71a9d0f7ee712899cc7113bbf2cd3dcb25808b
    > BUG: 1307208
    > Signed-off-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-on: http://review.gluster.org/13440
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    (cherry picked from commit bfd8f92490454f261330da34565334ed5decd0e1)
    
    Change-Id: I34e413d669fdfba343446e84fef5d8e9dd7bd1da
    BUG: 1308400
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/13441
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 3 Kaushal 2016-04-19 07:24:46 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.